Testing with this and can never get to work. Under verify script step select "Search file system.."




Type: file

Name: test123.txt

Directory \

Drives: C:

Action: Delete


Does nothing. I've tried all sorts of combinations. Any idea, or proper syntax?



0 Comments   [ + ] Show Comments


Please log in to comment

Community Chosen Answer


This may be a "special use" scenario - a call to KACE support may help clarify what the Action : Delete is actually used for (and if it should be working as intended here).

Otherwise, if you're just trying to delete a file (period), you could setup a script as follows:

1) Copy the Uninstall Msiexec Template - the other scripts don't appear to have the "Run a batch file option" (ignore if you prefer using vbscript/powershell).

2) In the Task section select, Verify - Verify a file exists...

3) Select On Success, then Run a Batch File and specify your commands to delete the file.

As mentioned before, this can also be done using vbscript or powershell, but the setup would be a little different.  Same idea, though.


Answered 05/16/2012 by: jverbosk
Red Belt

  • I've always done it with a batch script. That said, this should really work. I tested it as well, and could not figure out the proper syntax, whether Drives: C, Drives C:, or Drives C:\ etc. The same for directory /temp/, /temp, temp/, or temp. There are a lot of detail features like this where I am not aware of any documentation. Usually I can guess, but this appears cryptic.
Please log in to comment



"Search file system.." task in scripting is not working. This is a bug in version 5.3.

'Dell KACE| Quality Assurance Group'

Answered 05/17/2012 by: AbhayR
Fourth Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity