Trying to install K1000 agent on windows server 2008 machine in domain. Getting following error.

03/31/11 04:53:22 PM] Begin provisioning...
[03/31/11 04:53:22 PM] Executing Windows platform provisioning.
[03/31/11 04:53:22 PM] Probing tcp ports for accessibility.
[03/31/11 04:53:22 PM] Port 139 [netbios-ssn] open.
[03/31/11 04:53:22 PM] Port 445 [microsoft-ds] open.


[03/31/11 04:53:23 PM] Executing remote communications:

Initializing RPC
Connecting to ADMIN$
Copying service file
ERROR: Failed to copy file - /kbox/bin/KBRemoteService.exe - NT_STATUS_SHARING_VIOLATION


End of remote communications.

[03/31/11 04:53:23 PM] End provisioning run.
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


KACE Fully supports Windows 2008 Server. You will want to be cautious installing the agent on servers runing as it will conflict with the agent requirement of running .NET 1.1. (the .NET 1.1 requirement is soon to be removed)

How many systems have you deployed the agent to so far? How many of those are not working?
Is it just this one system you are having issues with?

Let's first double check the basics:
Are you deploying the agent using a hostname or IP address to managed node target?
If hostname, it is in DNS?
Have you tried deploying the agent using IP address?

What is the hostname of your K1000? Is it also listed in DNS?
Are there any strange characters in the hostname of the K1000 or the managed node target?

Sharing violation could be because the file is already present on the target system and is currently running from a previous attempt. Look on the target system for a Windows service called KBSH or similar and stop it before trying again.
Are you able to reboot the server to see if it clears the issue?

Are you using a more secure environment requiring NTLMv2?
If yes, you may need to enable the NTLMv2 options on the K1000 [settings > security settings > under "samba share settings" > try enabling both NTLMv2 options]
Answered 04/04/2011 by: tstaub
Second Degree Blue Belt

Please log in to comment
Answer this question or Comment on this question for clarity