When I installed Jave Runtime Environment .....and during uninstall or logging of and try to install some msi...
Im getting issue i.e Windows installer is crashing

The WI service cannot be accessed.This can occur if you are running windows in safe mode or if Windows service is not currently installed.
In eventvwr I found
Thw WS failed to start. It can be due to following . Illegal operation attempted on a reg key that has been marked for deletion

The same msi is working fine in other environment and I even unregistered and re-registered msi service

Please let me know what 2 do
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


If the MSI works elsewhere then your problem has to be localised to the machine. Rebuild it.
Answered 06/03/2011 by: VBScab
Red Belt

Please log in to comment
I used to get these a lot at my previous job. Don't take this the wrong way, but did you reboot the machine? 99% of the time this was all I had to do as Windows would clean up the registry key on reboot.
Answered 06/03/2011 by: spottedcoin
Senior Yellow Belt

Please log in to comment
Hung or failed msi's will sometimes leave msiexec.exe in a "stuck" state (you can usually see it in taskman) so subsequent installs won't start. As the previous posts mention, it likely that machine and if a reboot doesn't clear it, the rebuild it.
Answered 06/03/2011 by: jmaclaurin
Third Degree Blue Belt

Please log in to comment
Answer this question or Comment on this question for clarity