Hi,

we need to deploy the latest Java Runtime Enviroment. This is not the problem. But we have to specify a proxy Server in the Java Settings. Is there a command line on the installation to set a proxy server? Or maybe a reg key?

thanks for answers
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Seby,

You don't mention what you are using to package in your post, but the obvious thing to do would be to install Java and take a "snapshot" of the machine. Then change the proxy settings and perform an "after snapshot".

That should capture the changes you made and you should be able to work it out from there.

Thanks,

Dunnpy
Answered 03/15/2007 by: dunnpy
Red Belt

Please log in to comment
0
I just used RegShot to snapshot both my registry and my files. When I changed Java's proxy server, there was one file that got modified... It is a text file located at c:\Documents and settings\MY_USER_NAME\Application Data\Sun\Java\Deployment\deployment.properties. I can see in the deployment.properties file the following (and possibly others) were directly changed:

deployment.proxy.ftp.host=
deployment.proxy.https.port=
deployment.proxy.bypass.list=
deployment.proxy.ftp.port=
deployment.javaws.cache.update=
deployment.system.tray.icon=
deployment.version=
deployment.browser.vm.iexplorer=
deployment.browser.path=
deployment.proxy.http.host=
deployment.proxy.type=
deployment.proxy.https.host=
deployment.proxy.same=
deployment.browser.vm.mozilla=
deployment.capture.mime.types=
deployment.javapi.cache.update=
deployment.proxy.http.port=


If it were my project, I'd set all of those properties to how I want them and then include the deployment.properties file in my MSI getting deployed to the correct location.
Answered 03/15/2007 by: dlernstrom
Senior Yellow Belt

Please log in to comment
0
Hi,

Have a look at the following. This should help you out

http://itninja.com/question/how-do-you-roll-out-new-machines?2829&mpage=1&key=Java娮

More specifically, find the part with this quote -

Hi all,

Since posting this question I have done more investigation and discovered that there is another more clean way to figure this out.

Please see the following website -
http://java.sun.com/j2se/1.5.0/docs/guide/deployment/deployment-guide/properties.html

When I installed Java and made the necessary config changes the User-Specific deployment.properties file located at <User Application Data Folder>\Sun\Java\Deployment\deployment.properties was altered. I took a copy of this file and made it my System-specifc deployment.properties file. Using the <Windows Directory>\Sun\Java\Deployment\deployment.config file I was able to define where my deployment.properties file would reside.

When a new user now runs the application instead of a "default" user-specifc file the user now gets the system file that contains the information needed.

Thanks for all your help.....
Rgds,
Mark
Answered 03/16/2007 by: mark_holland21
Fourth Degree Green Belt

Please log in to comment
0
Setup your Deployment.properties file and put it in Windows\Sun\Java\Deployment.

I use this to force settings for all users
Should have something like this:
#
#Thu Jan 22 10:04:00 CST 2004
deployment.javaws.proxy.http=
deployment.javaws.logToFile=false
deployment.javaws.player.manager=0
deployment.javaws.proxy.setting=NONE
deployment.javaws.whenInstall=0
deployment.javaws.whatInstall=2
deployment.javaws.player.mode=1
deployment.javaws.jre.0.registered=true
deployment.javaws.jre.0.platform=1.4
deployment.javaws.logFileName=
deployment.javaws.jre.0.osname=Windows
deployment.javaws.jre.0.path=C\:\\Program Files\\Java\\j2re1.4.2_08\\bin\\javaw.exe
deployment.javaws.jre.0.product=1.4.2_08
deployment.javaws.jre.0.osarch=x86
deployment.javaws.jre.0.location=http\://java.sun.com/products/autodl/j2se
deployment.javaws.version=javaws-1.4.2_08
deployment.javaws.jre.0.enabled=true
deployment.javaws.proxy.httpproxyoverride=
Answered 04/04/2007 by: dsumners
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity