I have a weird problem. My system is in french and when I do an unattended JRE 1.5.0_9 setup, the internet explorer is not properly installed. (I use the following line to install if I do it manually, but the final deployment will be through active directory GPOs: [font="Courier New"]msiexec /i jre1.5.0_09.msi /passive)

If I go the java homepage and do the java instalation verification in french (because the website has detected that my browser is in french), the java control doesn't respond. However, if I force the language to english, the JRE is properly detected.

But if I do the same setup ([font="Courier New"]msiexec, without the [font="Courier New"]/passive switch), but in interactive mode and select the typical setup option, the JRE is detected both in english and french.

At first, I thought the problem was with my transforms that disable all the auto-update features, but even without them the unattended setup is incomplete.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Hi Alexandre,
you have to set the 'IEXPLORER' property to 1, either on the command line or via MST.
If you do a setup trough the UI, this property, which per default is '0', is set during the dialog phase.

If you want to install it in french with a AD-GPO, you have to extract the french language transform, first.
This can be done by 'msidb /d jre1.5.0_09.msi /w 1036' (MSIDB.EXE from the installer SDK).
Hope this helps.
Regards, Nick
Answered 12/09/2006 by: nheim
Tenth Degree Black Belt

Please log in to comment
0
I feel so stupid! IEXPLORER=1 fixed it. I was not sure if it was really necessary because, after all, java was partially running in IE... Even in a previous version (i think it was 1.5.0-6), JRE would refuse to work at all in any languages on my computers if IEXPLORER=1 was set!
Answered 12/09/2006 by: blanalex
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity