I'm having problems getting itunes to install without rebooting the workstation. 

I've tried:



Neither stopped the reboot after installation.  I didn't have this same issue with iTunes 10. 

Answer Summary:
Set the property IS_ASU to "0" and this CA will not execute and it will not reboot after install.
0 Comments   [ + ] Show Comments


Please log in to comment

Community Chosen Answer


I took a look in the iTunes64.msi and it seems that after InstallFinalize is set a Custom Acction called Set_REBOOT with the condition IS_ASU="1".

Set the property IS_ASU to "0" and this CA will not execute. I didn't test this, but you can do it very easy.

Also, you can create a MST and remove this CA from msi script.

Answered 05/22/2013 by: terebent
Brown Belt

  • Setting IS_ASU to "0" stopped the reboot. I overlooked that when I was making my changes. Thanks.
  • Thank you for this information!
Please log in to comment



Might want to try:


That is what I use in my .bat file to install iTunes and I do not recall needing to reboot with it.  From what I can tell, the /norestart works for everything but the AppleApplicationSupport installer, which is what requires the reboot=suppress option.

Answered 05/21/2013 by: andrew_lubchansky
Black Belt

  • Since itunes being a vendor MSI , check the custom action table , I have had many instances wherein the reboot was called for , from a custom action and i m a bit skeptical about the same custom action used in this case too. Also refer the log file, there has to be something related to reboot.
Please log in to comment

I assume you have tried the suggestions here?  http://www.itninja.com/software/apple/itunes/11-1184

This might help too: https://wiki.as.emory.edu/display/ECITDT/Packaging+iTunes+for+Windows

Answered 05/21/2013 by: jknox
Red Belt

  • Yes, I've looked at those suggestions, and they work fine for iTunes 10, but somethingseems to be different with the msi for 11. Specifically, I'm installing version 11.0.3
Please log in to comment
Answer this question or Comment on this question for clarity