Hi..
I am trying to install Application on D drive silently changing Default Directory to D Drive in Wise property.However, it installs on it defaul location. ie on C:\PF\..

How do i Divert the installation to D:\ instead of C:\

Any tweaks pls....
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Try it with the public property ROOTDRIVE.
You can also give this property as parameter via command line: msiexec.exe /I mypackage.msi ROOTDRIVE="D:\".

Usually without this property, msiexec will install on HDD with most free space.
Answered 11/25/2008 by: Jay Am
Senior Yellow Belt

Please log in to comment
0
How exactly are you changing default directory to D?

Jeeoo!
Santro
Answered 11/25/2008 by: zipsantro
Purple Belt

Please log in to comment
0
I tried both the ways

Changing the Propertly ROOTDRIVE
Passing property at command Line..... but no go
Answered 11/25/2008 by: mqs
Senior Yellow Belt

Please log in to comment
0
In this case you can't use "ProgramFilesFolder". Create a DIR (Program Files) and point it to TARGETDIR and then use this Dir as parent of your application dir.

Jeeoo!
Santro
Answered 11/25/2008 by: zipsantro
Purple Belt

Please log in to comment
0





Posts: 4
Score: 0
Joined: 11/24/2008
Status: online I tried both the ways

Changing the Propertly ROOTDRIVE
Passing property at command Line..... but no go

(in reply to zipsantro)
Report | Rate post | Post #: 4


RE: Installation on D Drive - 11/25/2008 7:09:18 AM


zipsantro
Senior Member





Use of Set Directiry Custom Action would the good and reliable solution for this requirement.
Answered 11/25/2008 by: zipsantro
Purple Belt

Please log in to comment
0
ORIGINAL: zipsantro
In this case you can't use "ProgramFilesFolder".
Not true. The engine will create the folder (and obviously any sub-folders) if it doesn't exist on ROOTDRIVE.
Answered 11/25/2008 by: VBScab
Red Belt

Please log in to comment
0
If I recall any "ShellFolder" directory will not take care of the ROOTDRIVE property value.
Answered 11/25/2008 by: AngelD
Red Belt

Please log in to comment
0
ROOTDRIVE = 'D:\' has always worked for me..

Make sure your application directory folder is not in Program Files as it will always pick C:\Program Files from the Environment(?)... I think your Directory Table is setup so your Application Folder has a parent of "ProgramFilesFolder" property and this will no change..

What you can do is add a custom action (as zipsanto suggests) in the Execure Immediate script "Set Directory", put it in after the CostFinalize action. Browse to your program folder you want to move and type in a path for it in the Directory Value field, ie D:\Program Files\MyApp

This will force it to the folder you want.. We are doing this in my environment for W2K3 Server Packages where the policy is to install the application into D:\Program Files\xxxx leaving the OS only in it's own drive on C:\ for backup and restore simplification..
Answered 11/26/2008 by: stevematt41
Senior Yellow Belt

Please log in to comment
0
ORIGINAL: stevematt41
Make sure your application directory folder is not in Program Files as it will always pick C:\Program Files from the Environment(?)...
No, it won't. The Directory table doesn't care what the environment variable is set to. All it consists of is a linked series of directory names and will cause the WI engine to create the structure defined therein on whatever ROOTDRIVE is set to. If there's no valid ROOTDRIVE property, it will create that structure on the disk with the most free space.

@MQS, what does a verbose log tell you?
Answered 11/26/2008 by: VBScab
Red Belt

Please log in to comment
0
Ok, sorry maybe not the Environment as is environment variables but it must start from somewhere, the Shell Folders keys in the registry?
Answered 11/26/2008 by: stevematt41
Senior Yellow Belt

Please log in to comment
0
Simply setting ROOTDRIVE to D:\ will not redirect the installation to D:\Program Files\ if you are installing to the ProgramFilesFolder. It will however work if you are not installing to a "shell folder".
Answered 11/26/2008 by: Jamie B
Orange Senior Belt

Please log in to comment
0
So what's the best solution for mqs then, adding a Set Directory custom action to force it into a particular folder?
Answered 11/26/2008 by: stevematt41
Senior Yellow Belt

Please log in to comment
0
After reading the OP requirement he isnt actually installing to the ProgramFilesFolder anyway (C:\PF) so setting ROOTDRIVE should suffice. Ensure that the value has a trailing backslash. ie D:\

Edit - Unless of course he refers to PF as Program Files. In which case, yes, he could use a set directory custom action.
Answered 11/26/2008 by: Jamie B
Orange Senior Belt

Please log in to comment
0
Answered 12/12/2008 by: mqs
Senior Yellow Belt

Please log in to comment
0
Add property
INSTALLDIR=D:\Program Files\{application folder}
Answered 12/12/2008 by: ratheeshtravi
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity