Hi everyone,

So I'm having a problem trying to get CCTK to make changes to our systems BIOS's. What I've done is I've embedded CCTK version 2.2.1 into our K2000 x86 boot environment using the KBEM. And that all seemed to install fine, however I find running the CCTK scripts as PreInstallation Tasks, I get mixed results. Sometimes the settings get applied (never all of them though) or sometimes the whole task fails. The thing is I can get these different results running the exact same task on different jobs. Different jobs being the exact same image deployment to two different units. Both units being the same model though. I've even had it run almost successfully on one unit, only to have it fail a second time on the exact same unit.

I've also played around with the installed cctkgui and created executables that I ran from within the Windows OS on the same unit only to find that, once again, not all settings get applied, or it fails completely. Honestly, based on my experience I would say that the application is buggy. However I have read postings by others here that it's working for them. So it must be something that I've done? Any help with this would be greatly appreciated.

Thanks in advance.

Steve

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

0
This sounds like issues with CCTK.  Have you tried version 3.0, http://en.community.dell.com/techcenter/enterprise-client/w/wiki/7532.dell-command-configure?  The next version of kbem will support it, but you could try the ui part again, or you could rename the command configure install folder to match that of cctk and kbem won't know the difference.


Corey
Answered 12/04/2014 by: cserrins
Red Belt

Please log in to comment
0

HI Cory,

Yeah, I've tried version 3 to see if that was the problem. I got the same results. I even back-reved to 2.0.1 and still got the same results. On multiple models as well. I've tried all these versions on Optiplex GX620s, 745s, 755s, 760s, 780s, 960s and 990s. So I'm positive that it's CCTK. but I'm stumped why it has worked for others.

Steve

Answered 12/04/2014 by: stwarog
Senior White Belt

Please log in to comment
0
do some of your pc have bios passwords and others do not.  What is exact command you are trying to run.
can you post the task for the CCTK call.
Answered 12/08/2014 by: SMal.tmcc
Red Belt

Please log in to comment
0

Hi Steve,

 

I’ve tried both with and without the bios password. I do get better results without, but that’s not practical, as all of our systems out there have the password set. I’ve pretty much tried all of the settings. Funny enough if I do get it to work, it almost always seems to be the same three that fail.

 

- Setting floppy to off (this one always sets itself to internal instead)

- Setting USB to no boot (this one doesn’t change at all)

- Setting NIC to WOL w/PXE (No change here either)

 

Here’s a copy of one of the tasks that I set up. As Imentioned earlier, I’ve tried this in many different formats to see if possibly Iwas having a syntax error.

 

 

start x:\cctk\x86\cctk.exe --valsetuppwd=XXXXXX --acpower=on--autoon=everyday --autoonhr=19 --autoonmn=0 --chasintrusion=silentenable --cpuxdsupport=enable--embnic1=on --fastboot=minimal --floppy=off --hddacousticmode=bypass --integratedaudio=enable--limitcpuidvalue=off --logicproc=enable --lowpowers5=disable --lpt=lpt1 --lptmode=ecp--mouse=off --numlock=on --osmode=disable --pcislots=disable --postf12key=disable--postf2key=disable --pwdlock=lock --rptkeyerr=enable --sata0=auto --sata1=off--sata2=off --sata3=off --serial1=com1 --serial2=com2 --serrdmimsg=on --smarterrors=disable--standbystate=s1 --usbctl=enable --usbportsfront=disable --virtualization=disable--wakeonlanbootovrd=enable --bootorder=legacytype,+hdd.1,+embnic,-cdrom,-floppy,-hdd.2

 

I’ve also tried the script with the syntax of having eachsetting on a separate line followed by the valsetuppwd value. Same results either way. Heres an example...


start /wait x:\cctk\x86\cctk.exe --acpower=on --valsetuppwd=XXXXXX

start /wait x:\cctk\x86\cctk.exe --hddacousticmode=bypass --valsetuppwd=XXXXXX


Thanks


Steve



Answered 12/08/2014 by: stwarog
Senior White Belt

  • This content is currently hidden from public view.
    Reason: Removed by member request
    For more information, visit our FAQ's.
Please log in to comment
0
Lets try it with a different approach.
on a machine with the bios set correctly export the current settings to a biossettings.txt file.
edit that file and remove all extra lines you do not need.
then zip that file up along with the x86 cctk.exe and the dll file in that directory.
SDQ9d4.jpeg
this is necessary because we are going to create a pre application script and it looks for the exe in the preinstall\xx directory.
Lets create the preinstall task
4w55Mw.jpeg

Answered 12/08/2014 by: SMal.tmcc
Red Belt

Please log in to comment
0

Hi Steve,

Well that was a good idea. I never thought to run it as an application. Unfortunately it still failed. I got a task error, with a return code of 2. ""The system can not find the file specified". I set it up exactly as you instructed. I've even gone into the peinst share to verify that it was there after I received the failure. And it was...


BTW, I tried that with version 2.2.1 Was that right?

Answered 12/08/2014 by: stwarog
Senior White Belt

  • version should not matter for the older machines, you need to get to v3 for the newer machines there are bios settings in 3 that 2 does not do.
Please log in to comment
This content is currently hidden from public view.
Reason: Removed by member request
For more information, visit our FAQ's.

0
Does your contents sub directory look like this?

and also point at the deployment and get that ID and go to .\peinst\scripts and edit ImagingTasks_XXX.xml and post that portion of the script

<Task ID="92">
<Name>set Bios</Name>
<WorkingDirectory>Y:\preinstall\92\contents</WorkingDirectory>
<CommandLine><![CDATA["Y:\preinstall\92\contents\cctk.exe" -i=BiosSettings.txt --valsetuppwd=password]]></CommandLine>
<Parameters></Parameters>
<PostTaskAction>None</PostTaskAction>
<KACETaskType>Application</KACETaskType>
<FileType>Exe</FileType>
<Type>PR</Type>
<Guid>15485ef0189f85</Guid>
</Task>

Answered 12/09/2014 by: SMal.tmcc
Red Belt

Please log in to comment
0

OK, thanks to your screenshot of your code I realized that I had zipped up the three files incorrectly. They were packaged from within a folder, so that folder was added under the contents folder, which made the path statement incorrect. I've fixed that and it's working great. In fact it works far more consistently than trying to run it from the CCTK folder on X: So thank you for that.

I still have one more problem though, hopefully you can help with. There are 2 settings that simply will not change their values. One is the "Remote Wake Up" setting. I've tried to set this to "Enable with boot to NIC". It doesn't change it just stays disabled. The other, "USB Controller" will not change to "No Boot", it stays enabled. There's a third setting, disabling the floppy, that works for half of my systems, but not the older models. X620s, 745s and 755s.

Have you seen this before?

Thanks

Steve

Answered 12/10/2014 by: stwarog
Senior White Belt

  • let me look at the couple. the disable floppy try setting that manually on one of those models and create a cctk output file on that machine to see if the wording is different.
    • I've checked on several models and they all read "floppy=disable". The weird thing is that it changes the setting to "internal", not disabled on the older models (GX620, 745, 755) The newer models (768, 780, 960 and 990) all behave properly. When I look into the compatibility listings for 2.2.1, all of these show up in the list.

      Thanks
      • do have the newest bios on these older models?
      • That is weird since the settings do not have a disabled option. According to the 2.2.1 pdf I have valid arguments for --floppy are on,off,auto,readonly,usb. Are you wanting to actually disable the drive or just take it out of the boot order?
Please log in to comment
0

Yes, I've made sure that all the models that I'm currently running in the test lab are on their most current bios.

Sorry, my bad. I meant to say "off". I wasn't thinking when I typed that last part I guess. So just to clarify, they all say

"floppy=off"

Answered 12/11/2014 by: stwarog
Senior White Belt

  • if you are trying to keep if from being in the boot you need to set that under bootorder --disabledevice
    • Our older systems are kiosk boxes, so I'm trying to do both. I don't want anyone to be able to boot from it, nor do I want them to access it afterwards when the OS has bootstraped
      • Make your life easy if you do have too many. If you do not need the drives and pull the power plug to the drives
Please log in to comment
0

Yeah, that got tossed around. But unfortunately it's not an option for a variety of reasons. We can successfully turn the setting back on. It just doesn't like to be off.

Any luck with the other 2 settings?

Answered 12/11/2014 by: stwarog
Senior White Belt

  • not yet been busy with updating masters prior to xmas break deployment, will still look at those.
    • Well it's much appreciated Steve. Thank You
Please log in to comment
Answer this question or Comment on this question for clarity