Hi there,
the headline says everything :-)

I have a 32bit MSI. During the setup I want to add a compatibility layer for the included EXE for WINXPSP3 to the registry. The keep need to be placed in the 64bit registry section. How I can do it?

Thx, Mike
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

2
Since the MSI is meant to 32-bit, ensure you set the Template Summary back again. Or, more simply, don't bother futzing with the MSI and just document the acceptance of the ICE80.
Answered 10/09/2015 by: VBScab
Red Belt

Please log in to comment
2
Thx for your help!
In the meanwhile I also found out a working solution:

1) Add a row in FeatureComponents table for an always installed feature
2) Add a row in Component table and set the Attribute field to 256
3) Add a row in the Registry table and set the Component field to the created obove

The attribute 256 reroutes to the 64bit path. Found it here: https://msdn.microsoft.com/en-us/library/aa368007(v=vs.85).aspx


Answered 10/09/2015 by: mikexmagic
Senior Yellow Belt

Please log in to comment
1

I have written a blog post now and have explained how to achieve this using Installshield.

http://www.itninja.com/blog/view/how-to-write-to-64bit-registry-path-from-a-32bit-msi-using-a-mst

Hope it would help you to achieve it using ORCA too.

Answered 10/09/2015 by: apptopack
Red Belt

Please log in to comment
0
Make that component having the registry as 64-bit.But you would have to resolve ICE error by editing the template summary again.
Answered 10/09/2015 by: apptopack
Red Belt

  • Ah, sorry. Cant follow :-( Can you explain it a bit more for msi newbies? ;-)
Please log in to comment
0
VBScab is correct. You can omit the ICE 80 instead of messing the MSI.
Answered 10/09/2015 by: apptopack
Red Belt

Please log in to comment
0
Either way you can achieve the output. Thanks for sharing your workaround.
Answered 10/09/2015 by: apptopack
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity