I need to import a .reg key into HKEY_CURRENT_USER using the K1000 and I cannot get it to work. I tried using the registry wizard and it just comes up with errors. Importing the key would be Ideal. This is something that will need to be run anytime we have a new user come in to a workstation.

I found this Article which goes over it.

https://support.software.dell.com/k1000-systems-management-appliance/kb/131517

But it no longer works with the current version of the k1000.

My machines are all windows 7x64

Any ideas?


1 Comment   [ + ] Show Comment

Comments

  • What is the error you get and can show the registry file?
    Perhaps the problem is not in KACE deployment.
    • It doesn't give an error. It shows as successful but it does not actually import the regfile.

      Kbot Config Info - Finish
      runkbot ----- launching [path='C:\ProgramData\Dell\KACE\kbots_cache\packages\kbots\60' program='kace9896.bat' parms='' wait='true'] -----
      runkbot ----- completed [exitCode=0] -----
      runkbot ----- launching [path='%WINDIR%\SYSNATIVE' program='regedt32.exe' parms='/s C:\ProgramData\Dell\KACE\kbots_cache\packages\kbots\60\Reg_Settings.reg' wait='true'] -----
      runkbot ----- completed [exitCode=0] -----
    • The reg file saves everything into this key and subkeys under it.

      [HKEY_CURRENT_USER\Software\XtenderSolutions]
    • I figured out the issue. Because of the key location (HKCU) it must be run while the user is logged on. Now to figure out the best way to put this all into RunOnce so it auto runs when a user first logs in.
Please log in to comment

There are no answers at this time

Answers

Answer this question or Comment on this question for clarity
Admin Script Editor
Admin Script Editor is an integrated scripting environment available free here at ITNinja

Share