Hi,

I've got a Vendor MSI. (SQL Server management Studio) in this MSI the default is that everything is being installed.
According to the windows installer SDK I can set the value of "level" in de feature table to "0"
So the According feature is not installed by default.

But, As soon as I change one "level" to "0" all de features are being disabled by default.

Example:

In the feature table the row "SQL_DatabaseSamples" has a level of 100.
The Property "INSTALLEVEL" is "90"

When I change the feature "SQL_DatabaseSamples" to level 80 (or just "0") ALL the features are being disabled by default.

My question:

In what way should I change the level so that certain features are disabled by default. (The "Entire Feature will be unavailable" Option, red cross )
Or should I look for my solution in another direction?

Thanks in advance!
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Set the INSTALLLEVEL to 100 and make sure the ADDLOCAL property has value of the features to be installed separated by ";"

These properties can be passed at command line also while installtion.
Answered 08/03/2006 by: Lillude
Senior Purple Belt

Please log in to comment
0
If you don't want to mess around with that...

Just find which features you don't want to install ... delete them and save to MST...

This way you don't have to mess around with InstallLevel and possibily stopping the execution of some Custom Actions...

Full install available by MSI - Custom install available by MST
Answered 08/03/2006 by: gmorgan618
Blue Belt

Please log in to comment
0
install available by MSI - Custom install available by MST

Thanks, I think I will try that, A bit different.

Create an MST with only the features I want (With Wise Package Studio)
Apply the MST on the MSI with Orca
Deploy the MSI.

I also will look into the solution of Lillude.
Answered 08/09/2006 by: subsense
Purple Belt

Please log in to comment
0
ORIGINAL: Lillude

Set the INSTALLLEVEL to 100 and make sure the ADDLOCAL property has value of the features to be installed separated by ";"

These properties can be passed at command line also while installtion.

The value of the ADDLOCAL property is a list of features that are delimited by commas, not ";"
But I think this is the best option. Thanks!


Answered 08/09/2006 by: subsense
Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity