Our new version of KACE has included the following line as a header in every email sent:
-+-+-  Please reply above this line to add a comment  -+-+-

I want to edit this line.  Where is it set?

-Kent
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

1
Update - there is a way to edit;

The text is appended to all the notification emails by default

> Skip "Please reply above this line" from the email notifications
UPDATE KBSYS.SETTINGS SET VALUE ='' WHERE NAME='HD_REPLY_DELIMETER'

> Update the delimeter characters used with "Please reply above this line" on email notifications
UPDATE KBSYS.SETTINGS SET VALUE ='--######--' WHERE NAME='HD_REPLY_DELIMETER'

Hope it helps someone.

Answered 10/07/2016 by: svmay
Sixth Degree Black Belt

  • http://www.itninja.com/blog/view/please-reply-above-this-line-on-email-notifications
    • How and where do I execute this script in my K1000?
  • How and where would I execute this script in the K1000?
    • You can realize this with an custom ticket rule.
      • Thanks for the quick reply. I'm not sure if I did this right, but I added a rule, checked Run update query, copied the script in and set the rule to run on ticket save. I receive the below error when the rule runs:

        Executing Select Query... 12/01/2016 10:15:34> mysqli error: [1064: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'and (HD_TICKET.ID = 209)' at line 1] in EXECUTE(" and (HD_TICKET.ID = 209) ")
      • Can you post your sql select, sql update and your settings?
      • I found the error in the script. However, now I receive this error:

        "12/02/2016 12:04:38> Starting: 12/02/2016 12:04:38 12/02/2016 12:04:38> Executing Select Query... 12/02/2016 12:04:38> selected 1 rows 12/02/2016 12:04:38> Executing Update Query... 12/02/2016 12:04:38> mysqli error: [1142: UPDATE command denied to user 'B2'@'localhost' for table 'SETTINGS'] in EXECUTE("UPDATE KBSYS.SETTINGS SET VALUE ='--Please log into the ticket system to update your ticket--' WHERE NAME='HD_REPLY_DELIMETER'") 12/02/2016 12:04:38> Ending: 12/02/2016 12:04:38"
Please log in to comment
1
Is it possible to create a custom rule, like the 'EmailOnClose' rule?
So you can customize the mail as you like ..?


Answered 09/16/2016 by: svmay
Sixth Degree Black Belt

  • I've create a custom ticket rule for that - so the sending mail has no line at the beginning
Please log in to comment
0
Hi Kent

Since the 6.3 server update there is a new line appear in email notification ticket and we cannot disable it or edit it.
It is was made by the engineer after customer uservocie request.
Actually there is no fix or change schedule for this.
Thanks
Answered 04/27/2015 by: Bertrand_v
White Belt

Please log in to comment
0
Not a fan of this line.  When I close a ticket I do not want them to reply to it!  
Answered 02/10/2016 by: JSenesap
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity