When clicking on the machine action icon in the KBOX Management Center to launch Remote Control or another Machine Action, you may receive the following error message: Unable to run Machine Action. Please check your Microsoft Internet Explorer Security Settings.

In order to resolve this error, verify the security settings for the Trusted Sites zone in your Internet Explorer ... Tools .. Internet Options on the machine you use to browse the KBOX Management Console.

INTERNET EXPLORER 6
Launch Internet Explorer 6 and navigate to:

1. Tools > Internet Options > Security
2. Select Trusted Sites Icon
-Add Kbox IP address to the zone
-Require Server Identification (Uncheck)
3. Click 'Custom Level' button
-Reset to Low or Medium Low
4. Under 'ActiveX Controls and Plugins'
-Automatic Prompting for ActiveX controls > Enable
-Download unisgned ActiveX controls > Enable
-Initialize & script ActiveX controls not marked safe for scripting > Enable
-Run ActiveX controls and plugins > Enable
5. Click 'OK'
6. Click 'Yes'
7. Click 'OK'

INTERNET EXPLORER 8
Launch Internet Explorer 8 and navigate to:

1. Tools > Internet Options > Security
2. Select Trusted Sites Icon > Sites Button
-Add Kbox IP address to the zone
-Require Server Identification (Uncheck)
-Click Close
3. Custom Level > Medium
4. ActiveX Controls Plugins
-Allow previously unused ActiveX controls > Enable
-Allow scriptlets > Enable
-Automatic Prompting for ActiveX controls > Enable
-Download unisgned ActiveX controls > Enable
-Initialize & script ActiveX controls not marked safe for scripting > Enable
-Run ActiveX controls and plugins > Enable
5. Click OK to close Security Settings Window
6. Click OK to close Internet Options Window

MACHINE ACTION SETTINGS:

1. Log into the KBox Admin UI
2. Settings > Control Panel > General Settings
3. Scroll down to Machine Actions > Edit Mode
4. Verify the path variables to the VNC Executable on the PC
-Default is "%ProgramFiles%\\ultravnc\\vncviewer.exe" KACE_HOST_NAME [change this to reflect the actual path, if needed]
5. Click 'Set Actions' button
If your Internet Explorer settings are correct, and you continue to receive this error, also verify that the executable for the Machine Action command is in your system path. For example, if you are using the Dameware option, the path to dwrcc.exe must be in your system path for the command to launch.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
"%ProgramFiles%\\ultravnc\\vncviewer.exe"

Note: If running Windows 7 64-bit with IE 8, you will need to hardcode the path to the vncviewer.exe.
%ProgramFiles% will not work and you will receive the following error, even though your security settings are correct.
"Unable to run Machine Action. Please check your Microsoft Internet Explorer Security Settings. "


"C:\\Program Files\\ultravnc\\vncviewer.exe"
Answered 05/18/2010 by: KevinG
Purple Belt

Please log in to comment
0
Hi,

I've configured out Win 7 32-Bit with IE 8, but cannot initialize UltraVNC within IE/KACE. It gives the Machine Action error message.

Are there any other settings that must be configured?
Answered 12/16/2010 by: londeaux
Green Belt

Please log in to comment
0
How to set Internet Explorer Security Settings for use with the KBOX remote control feature (Unable to run machine action error)

http://www.kace.com/support/kb/index.php?action=artikel&cat=1&id=518&artlang=en

Note: When using Windows 7 64-bit and IE8 you must use the full path to the vncviewer.exe in the machine action settings.

Example:"C:\\Program Files\\ultravnc\\vncviewer.exe" KACE_HOST_NAME

If your Internet Explorer settings are correct, and you continue to receive this error, also verify that the executable for the Machine Action command is in your system path. For example, if you are using the Dameware option, the path to dwrcc.exe must be in your system path for the command to launch.
Answered 12/26/2010 by: KevinG
Purple Belt

Please log in to comment
Answer this question or Comment on this question for clarity

Share