I've searched google, bing, and this site trying to find an answer to my problem with no luck.  Either I'm blind or I'm missing something.  We have non-admin users that need to use sites that take advantage of the IE9 Shockwave Add-On.  Every time they go to the site, they get the yellow bar asking to allow, problem being non-admin can't allow it.  Since we can't make them admin's and they are supervised, is there a way to push a registry key that would Allow Shockwave to run on all sites without admin permissions.  I know I can allow it from within IE on an admin user, but that does not help me out.

 

Any and all help is greatly appreciated.


Thanks

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

1

3. Check browser settings (Internet Explorer)          

http://helpx.adobe.com/shockwave/kb/troubleshoot-shockwave-player-installation-windows.html

Answered 02/13/2013 by: jagadeish
Red Belt

  • Thank you for the link, but that is already set on the image.

  • Why haven't you deployed the Shockwave plugin to the users via your normal software deployment method?

  • It is already deployed on the image that is on these machines. Apparently this is something that did not pop up before so was not set on the image.  It means a fix as I'm trying to avoid reimaging.

Please log in to comment
0

Not sure if you found a solution to this but you can try this.

 

If you open manage add-ons in internet explorer. Then from the drop down select all add-ons.

Once you do this, scroll down the list of add-ons until you find the one you want. Double click to upen the properties menu. Look for the Class ID line:

Then you can create a bat script or whatever to add the following key the the HCU registry.
 
HCU\Software\Microsoft\Windows\CurrentVersion\Ext\Stats\<ClassID of plugin>\Iexplore\AllowedDomains\*
 
In turn you can load the default user ntuser.dat file using the reg load command and add it to that so new users get it from the get go.
Answered 12/05/2013 by: PhillipR
White Belt

Please log in to comment
Answer this question or Comment on this question for clarity