I am sequencing an application for the very first time...
I noticed the following things while sequencing.

Between Begin Monitoring and Stop Monitoring.....we install the application
why the installed application does'nt show in Add remove programs or in Registry (HKLM\SOFTWARE\Microsoft\windows\currentversion\uninstall)....??
If the above is true, that means the application was not installed

I got an issue while launching one shortcut post Monitoring in the sequencer (Lauch all/launch)...the error message shown is "The sequencer could not stop the "MSI Server" service. Error 109. The pipe has been ended and got stopped". Again if I stop the process and relaunch the shortcut, this time its not giving any sort of error.
Any explaination for this is highly appreciated.

Eventhough the above shortcut from sequencer was launched successfully, however none of the shortcuts in startmenu/desktop are working. The error message occuring was "Installation directory setting is missing. Please rerun setup". shortcut target path is also existing...Really struggling to resolve this.
Please help me
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

1
Hi,

The MSI service error sounds like an issue with the repair being triggered when you start the virtualized app. Have you started your application during the monitoring phase? This might help to solve the issue if the repair runs succesfully at that stage (and thus is not needed anymore in the launching phase).

2nd error sounds like a message from the application itself. If the above true, the 2 errors might be connected and it should solve this 2nd error as well.
Answered 12/31/2010 by: Rheuvel
Brown Belt

Please log in to comment
1
ok let me check...when testing the raw media..desktop and startmenu shortcuts were launched successfully...

and wht abt

Between Begin Monitoring and Stop Monitoring.....we install the application
why the installed application does'nt show in Add remove programs or in Registry (HKLM\SOFTWARE\Microsoft\windows\currentversion\uninstall)....??
If the above is true, that means the application was not installed ..
Answered 12/31/2010 by: rvrajendra
Orange Belt

Please log in to comment
1
if it doesn't get installed during monitoring, try running it it logging while monitoring and see why it fails.
Answered 01/03/2011 by: Rheuvel
Brown Belt

Please log in to comment
Answer this question or Comment on this question for clarity