I have a big problem since several days and I don’t manage to find the reason of it and I neeeeed your help ;-)

I am trying to deploy an msi package that I did (that first copy files into program files, and then launch an exe with argument).

I have configured my program like that :
General :
Command line : program.msi /qb
Start in : c:\
Run : Normal

Environment :
Program can run : only when a user is logged on
Run Mode : Run with administrative rights (and allow users to interact with this program) (to let me see if there are errors)
Drive mode : Run with UNC name.

When I am watching my client logs (execmgr.log) I have that :

Command line = "C:\WINDOWS\System32\msiexec.exe" /i "C:\WINDOWS\System32\CCM\Cache\FR10000D.1.System\program.msi" /qb, Working Directory = c:\

Here it is for my configuration.

Now, when my program is advertised and ready to launch I have an alert box saying :
"unable to install because a newer version of this product is already installed” and in my log file I can read :
'Script for package...failed with exit code 1603'

Moreover, if I start manually my program from the command line prompt (from the client too) I don’t have such message and my program runs and installs successfully.(and I precise with exactly the same command line as noted above)

Please could you advice me about that problem that makes me crazy for several weeks ?
I have made a lot of tests but for the moment it doesn’t work.

Thanks a lot.

P.S:Sorry if I make mistakes but I am not english ;-)
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Si tu es pas Anglais es-tu français ? car je pourrais te répondre en français
Answered 06/21/2005 by: simonmsi
Yellow Belt

Please log in to comment

oui je suis francais !
Par contre j'espère que le fait de continuer notre discussion en francais ne dérangera pas les administrateurs.

For the moderators : Please do not lock the topic, as the user prefers to answer me in French.If you still want we continue to speak in English, let me know.
Moreover, if I have an answer, I will try to translate it in english for the forum ;)
Answered 06/21/2005 by: bigstyle
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity