Hi guys,

I have a newly created MSI that cannot proceed because it requires a strong SA password. I've already read through this article:


During runtime the following error is received: "A strong SA password is required for security reasons. Please use the SAPWD switch to supply the same. Refer to readme for setup details."

MSDE merge modules
SQL Server merge modules

MSDE merge module doesn't allow blank SA passwords by default.

Microsoft is recommending bootstrapping the MSDE .EXE to an installation rather than using the merge modules to install MSDE with an installation.

Wise makes this easy for you by adding the MSDE to the prerequisites page in Installation expert. Follow the steps below to add MSDE runtime to an .EXE wrapper:
In Installation Expert, select Build Options page and select Single File .EXE from the .EXE options drop down list. You may receive an error message indicating to change the Media type if you have external uncompressed files or external cabs set in the media options. A Single file .EXE (only valid for files inside .MSI) can only be used when the Media type of internal compressed files. If you have the Media page set to external uncompressed or external cabs, you need to use the .EXE that launches external .MSI option.
Select Prerequisites page from Installation Expert.
Click Add then select Runtimes.
If the MSDE 2000 Release A runtimes is not on your computer:

1. Select Help > Download Redistributables. Mark the Other Vendors' Web Site option and download the MSDE 2000 runtime.
2. Double-click the downloaded MSDE2000A.EXE to extract the MSDE installation files to your computer.
3. Specify the path to the MSDE files when prompted when incluyding the runtime

The MSDE runtime will appear in the list. Selecting this will include the runtime in an .EXE wrapper that is placed on the computer prior to executing the .MSI. The MSDE runtime should be on the computer to add it here, but can be downloaded by following the instructions on the MSDE Release A Runtime dialog during the process of including the runtime.

If you have a blank password, this will cause this error to appear:

If you would like to use a blank SA password, you can set BLANKSAPWD=1 in the property table of the merge module. Included with this article is a link to Microsoft's article on the switches that can be used for the MSDE setup.

This issue is also applicable to SQL Server merge modules.

After I've done all of this, the creation of a new installation file, cannot proceed because of the error: "The runtime file C:\Program Files\Altiris\.....\Runtime\Restart.exe" cannot be found, I already chose to download runtime but I can't find the Restart.exe in the available runtimes, any suggestions?

Another question, can I just set the BLANKSAPWD=1 for the installer to proceed? If so, how exactly? I do not know where to find the property table of the merge module as said in the article.

My current environment: Wise Package Studio 7, Windows XP Pro SP2, using SQL Server Merge module in the MSI created

appreciate if anyone can help :)
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Answered 12/10/2010 by: wise.reddy
Yellow Belt

Please log in to comment
How to create a password protected dialog in wise package studio
Answered 12/10/2010 by: wise.reddy
Yellow Belt

Please log in to comment
Please don't hijack threads, especially ones which are almost a year old.

Re-post your question in a new thread.
Answered 12/10/2010 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity