We were able to make the script and use the run now and it reports back that the script completed successfully with no errors. And when you check on the machine it was pushed too, the UltraVNC file is on the machine. However, when you try to use viewer on a different machine to remote into the machine, you receive a "Failed to connect to server!" error....I have tried to do this multiple ways and am not having any success. Please if anyone else can tell me if they actually got it to work and how, it would be greatly appreciated.

1 Comment   [ + ] Show Comment

Comments

  • Use AEROADMIN and stop torturing yourself
Please log in to comment

Answers

1

I used the UltraVNC wizard under scripting-configure policy and it worked. I was not successful installing it without using the wizard.

Answered 05/02/2012 by: ckubaska
Fourth Degree Brown Belt

  • I tried the wizard and it shows that it completed, but when you try to vnc to the target machine, it does not work and gives the "cannot connect to server" error.
Please log in to comment
1

We created an installer from scratch. One for x86 and one for x64. It creates the program files directory, copies the ini file, then adds a registry value for using AD credentials. Then we install the program via the MSI file and we delete all the icons from both the desktop and start menu. (To keep the program somewhat hidden from the user, they know it's installed, but we don't want them using it, even though it's locked down with AD)

We wanted to use the latest version of UltraVNC, which the kbox does not use. UltraVNC recently came out with an MSI file that makes installing it much easier.

I have recieved that error before when trying to use a non UltraVNC viewer to view the desktop of a UltraVNC server. There was one other time I saw that error, but I cannot recall what the issue was.

Answered 05/02/2012 by: chadbaldwin
Senior White Belt

  • Thanks, I believe that is something we tried also, so that is why I am posing the question. I did read some comments about it having issues with 5.3 version of Kace. So trying to find a work around.
  • Are you trying to use AD authentication?
Please log in to comment
1

I am using Tight VNC on Windows 7 and this Works for me.

The vnc.reg files contains the following:

Windows Registry Editor Version 5.00

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\TightVNC\Server]

"ExtraPorts"=""

"QueryTimeout"=dword:0000001e

"QueryAcceptOnTimeout"=dword:00000000

"LocalInputPriorityTimeout"=dword:00000003

"LocalInputPriority"=dword:00000000

"BlockRemoteInput"=dword:00000000

"BlockLocalInput"=dword:00000000

"IpAccessControl"=""

"RfbPort"=dword:0000170c

"HttpPort"=dword:000016a8

"DisconnectAction"=dword:00000000

"AcceptRfbConnections"=dword:00000001

"UseVncAuthentication"=dword:00000001

"UseControlAuthentication"=dword:00000000

"LoopbackOnly"=dword:00000000

"AcceptHttpConnections"=dword:00000001

"LogLevel"=dword:00000000

"EnableFileTransfers"=dword:00000001

"BlankScreen"=dword:00000000

"RemoveWallpaper"=dword:00000001

"EnableUrlParams"=dword:00000001

"Password"=hex:52,b8,fe,97,06,f0,92,e5

"AlwaysShared"=dword:00000000

"NeverShared"=dword:00000000

"DisconnectClients"=dword:00000001

"PollingInterval"=dword:000003e8

"AllowLoopback"=dword:00000000

"VideoRecognitionInterval"=dword:00000bb8

"GrabTransparentWindows"=dword:00000001

"SaveLogToAllUsersPath"=dword:00000000

"RunControlInterface"=dword:00000001

"VideoClasses"=""

This deletes the viewer, so all they have there is server. Kind of a wierd way around it, but it has been working for me.
 
Hope this helps.
Answered 05/02/2012 by: WGM_Jeff
Fourth Degree Black Belt

Please log in to comment
1

I use VNCed. They have a vnc msi creator (which gives you tons of options). After you have the MSI created, it pretty easy to deploy.

https://sites.google.com/site/dev4webapps/apps/development/vnced/vnced-app-related/ultravnc-msi-creator

Answered 05/03/2012 by: dchristian
Red Belt

  • Thanks, I already downloaded it as an msi. It is trying to figure out why it acts as if it has installed, but you cannot connect to the machine.
Please log in to comment
0

1. Create the default version to start.
2. remove the default setup.exe and replace with UltraVNC_1.0.9.6.1_setup.exe.  Leave the .inf and .ini files alone.
3. Remove everything from 'On Success'.
4. Replace with:

1. Launch ON PROGRAM
Directory: $(KACE_DEPENDENCY_DIR)
File: UltraVNC_1.0.9.6.1_setup.exe
check 'wait for startup'
parameters:/loadinf="$(KACE_DEPENDENCY_DIR)\ultravnc.inf" /verysilent
2. Run a batch file:

Batch file:

REG ADD HKEY_LOCAL_MACHINE\SOFTWARE\ORL\WinVNC3\Default /v Password /t REG_BINARY /d 317c13ddb544c6c7

REG ADD HKEY_LOCAL_MACHINE\SOFTWARE\ORL\WinVNC3 /v MSLogonRequired /t REG_DWORD /d 0

REG ADD HKEY_LOCAL_MACHINE\SOFTWARE\ORL\WinVNC3 /v NewMSLogon /t REG_DWORD /d 0

REG ADD HKEY_LOCAL_MACHINE\SOFTWARE\ORL\WinVNC3 /v DisableTrayIcon /t REG_DWORD /d 1

REG ADD HKEY_LOCAL_MACHINE\SOFTWARE\ORL\WinVNC3\Default /v AllowEditClients /t REG_DWORD /d 0

REG ADD HKEY_LOCAL_MACHINE\SOFTWARE\ORL\WinVNC3\Default /v AllowProperties /t REG_DWORD /d 0

REG ADD HKEY_LOCAL_MACHINE\SOFTWARE\ORL\WinVNC3\Default /v AllowShutdown /t REG_DWORD /d 1

check 'wait for startup'
leave parameters blank.

3.  Launch a program
Directory: SYS
File: cmd.exe
check 'wait for startup'
parameters:  /C "copy "$(KACE_DEPENDENCY_DIR)\ultravnc.ini" "C:\Program Files\UltraVNC\ultravnc.ini" /Y"

 

Answered 05/23/2012 by: brian_klocek
Third Degree Brown Belt

Please log in to comment
Answer this question or Comment on this question for clarity

Share