Afternoon,

 I'm using the getcomputername.exe along with the command line of Getcomputername.exe /dialog /timeout:120 as a preinstallation task. The dialog box comes up and I am able to input in a pc name. As a Mid-Level task I have the Setcomputername.exe with command line SetComputerName.exe. However when my imaged PC is done I look at the PC name and it doesn't reflect what I had indicated.

The Get and Set are at the very first of thier respective tasks. I've also verified it is writing to the 'petemp' folder on my kace box.

Any ideas?

Answer Summary:
Cancel
1 Comment   [ + ] Show Comment

Comments

  • Are you using the appropriate arch versions of those tasks (x86 and x64)?
Please log in to comment

Answers

0

Are you using a sysprep image? If so, make sure you have this line in the appropriate area of your unattend file: <ComputerName>*</ComputerName>

If you do not have this line, the set exe is not able to inject the name into the unattend file. Since you can see it in PETemp, you know the get task is working. If you uncheck auto restart when you deploy the image, then browse to your unattend file in Kace when it's done, you should see the new name in the unattend: <ComputerName>NameFromGetTask</ComputerName>

Answered 01/22/2014 by: SDNBTP
Third Degree Blue Belt

  • prior to updating to version 3.580613, the unattended xml was created on the root of C. With the update the unattended xml file is no longer created there, and now it does not properly name the PC. In the new version does it get created somewhere else? Or where should it be created?
    • Perhaps better served in a new thread my friend. Since my original question was answered and resolved.
Please log in to comment
Answer this question or Comment on this question for clarity
Admin Script Editor
Admin Script Editor is an integrated scripting environment available free here at ITNinja

Share