We have just updated our Kace 1000 agent to 6.2.1020 and are currently running into an issue where it doesn't appear to be updating client systems. If I run a force check in, and then a force inventory to see what version agents are now installed, we continue to see the older 5.5. If I manually install, the inventory reflects the new information. Any ideas on what I need to be troubleshooting?

Thanks so much.

Answer Summary:
6 Comments   [ - ] Hide Comments


  • Under Settings > Provisioning > Update Agents does it show version 6.2 for the Advertised Agents? If not make sure you add it in there, manually if necessary and it should update. Alternatively try updating to 6.0 agent first. It might be that it doesn't like that big of a version skip.
  • Hi, thanks for the post - yep, we seem set there. I will see if going from 6.0 makes things play nicer.
  • Ensure that updating the Agent is Enabled. When you advertise or download new agents, the checkbox is toggled off by default. You need to re-enable it.
  • You might also double check who are you targeting for the update if not all devices? If you are hitting a label only, then those machines might not be apart of that able.
  • According to Dell, there may be an issue with the older Agent as it is ver. 5.5.30275 and the update only works with ver. 5.5.30276
  • I'm also having the same problem but updating the agent from v6.0.1079 to v6.2.1025. The targeted systems are regularly checking in with the K1000 and the Agent Update is enabled for those targeted systems.
Please log in to comment

Answer this question or Comment on this question for clarity


Under Settings > Provisioning > Update Agents - Ensure that you have enabled updates, and targeted the correct labels or all devices. K1000 automatically disables updates to agents when a new agent version is applied to the server in order to allow you to decide to roll them out as you see fit. 

You should also ensure that any GPO's you may have in place are also updated any time you update the agents.
Answered 10/25/2014 by: cblake
Red Belt

Please log in to comment