Hi All,

I am rolling an application that only works properly after a reboot because it installs a service. I am deploying the application using Group Policy and therefore using a silent install. What I would like to happen is for the machine to automatically reboot after the package has installed itself and I would like this to happen with no user input.

I've tried setting the REBOOTPROMPT=S property but this has not worked? What else do I need to configure to reboot automatically?

Many thanks
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
You can try this to force a reboot. Also look at options with the /passive switch set.


/forcerestart Always restart option. The installer always restarts the computer after every installation.
Example: msiexec /package /Application.msi /forcerestart

Note The equivalent Windows Installer command line has REBOOT=Force set on the command line.
Answered 11/15/2005 by: Foleymon
Orange Senior Belt

Please log in to comment
0
Many thanks for your input Foleymon. I placed both the REBOOT=Force and the REBOOTPROMPT=Suppress values into the Property Manager table in InstallShield and this did the trick but created a new problem for me.

In my package I am using registry entries in the HKLM\Software\Microsoft\Active Setup\Installed Components to run "MsiExec /fs {PackageCode}" in order to place shortcuts into the users Quick Launch or to fix registry entries that must exist in HKCU.

The problem I have now is that as soon as somebody logs on for the first time the package is run but then reboots automatically on first log on due to the two properties I have placed into the package. I only want the package to reboot when first installed and not on a repair. Is this possible?

I've tried running the command MsiExec /fs {PackageCode} REBOOT="ReallySuppress" but the property in the package itself overides this.
Answered 11/16/2005 by: dreamsurfer141
Senior Yellow Belt

Please log in to comment
0
I fixed the above by changing the condition on the ScheduleReboot standard action to NOT Installed then deleting the REBOOT=Force from the Property Manager table but kept the REBOOTPROMPT=S therefore the reboot only occurs when the package is installed but not during Maintenance or Repair.
Answered 11/16/2005 by: dreamsurfer141
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity