In Wise Package Studio, I added security settings for a folder.

DOMAIN\Power Users
DOMAIN\Domain Users

I added Domain users to the security, otherwise the application I created won't work for normal users connected to the domain.

However when I take a look at the security tab of that folder on the machine where is MSI is installed, the settings seems to be correct, but when I want to look into the folder it results in an access denied.

I connected with an other computer to the c$ admin share to see the persmissions, and it returns directly an error: "The permission on folder are incorrectly ordered. which mag cause some entries to be ineffective". After pressing OK the permissions are ordered and I can look inside the folder on the machine where is MSI is installed.

Can someone tell me what I did wrong?
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Hi Dennis,
stay away from using the builtin permission functionality of Windows Installer (which uses the LockPermission table). It has error and produces unpredictable results. And even worse: It kills the inheritance of the permissions.
Use a tool like SetACL or CACLS in CustomAction to set permissions of files, folders and registry keys.
Regards, Nick
Answered 11/01/2006 by: nheim
Tenth Degree Black Belt

Please log in to comment
Answer this question or Comment on this question for clarity