/bundles/itninjaweb/img/Breadcrumb_cap_w.png
Packaging Firefox 3.5.5 for silent installation via SCCM deployment. Got the package almost working as I want with specific config settings for our corporate environment. The last thing I want to do is import a user's existing Internet Explorer bookmarks but not have them see the Firefox Import Wizard.

I've added a fake profile.ini to prevent the Import Wizard from displaying if there isn't an existing Firefox profile on the PC (found this on a link from an AppDeploy message board page).

And I have a customized prefs.js file I'm adding to C:\Program Files\Mozilla Firefox\defaults\profile, and in that file is this line:
user_pref("browser.places.importBookmarksHTML", true);

Yet when I fire up Firefox after installing it, it's not importing my existing bookmarks.
0 Comments   [ - ] Hide Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.
Answer this question or Comment on this question for clarity

Answers

0
Does it work if you perform this manually?
Check the steps at: http://www.littletonville.com/asd/2008/06/how-to-recover-bookmarks-after.html
Answered 12/15/2009 by: AngelD
Red Belt

Please log in to comment
0
No luck, I'm afraid. Plus an update to what I wrote earlier: I'm still having the Import Wizard show up, too, even with the script to create a fake user profile.

But back to the bookmarks: I noticed that after making the changes as outlined in the link you provided, when I restart Firefox, then type about:config and check the browser.places.importBookmarksHTML value, it's set back to false even though I manually set it to true.

I also have this line in C:\Program Files\Mozilla Firefox\defaults\profile\prefs.js:
user_pref("browser.places.importBookmarksHTML", true);

I thought that prefs file would override any user-specific settings. Or maybe I'm misunderstanding something.

So two mysteries left to solve: why the import bookmarks setting keeps going back to False even if I manually set it to True, and how (if it's possible) to prevent the Import Wizard from running but still import the user's bookmarks.
Answered 12/15/2009 by: RonW
Green Belt

Please log in to comment
0
See if you can find some answers at:
http://www.mozilla.org/unix/customizing.html
https://www-secure.symantec.com/connect/articles/custom-firefox-install-part-1
https://www-secure.symantec.com/connect/articles/custom-firefox-install-part-2
https://www-secure.symantec.com/connect/articles/custom-firefox-install-part-3
https://www-secure.symantec.com/connect/articles/custom-firefox-install-part-4
https://www-secure.symantec.com/connect/articles/custom-firefox-install-part-5
Answered 12/15/2009 by: AngelD
Red Belt

Please log in to comment