For the life of me I cannot get File Synchronization to work. I need to push out a zip file and have it unzip. I attached the zip file to a software entry in the software inventory section then created a new File Synchronization.
On the File Synchronization detail window:
  • I have the software title selected and it recognizes the zip file that I already attached
  • The location is C:\Adobe
  • Location User and password is just the default for the server
  • It's enabled
  • Create Location is checked
  • Persistent is checked
  • I have my labels selected for where I want the file deployed
  • and I have my deployment window for 18 - 7 (24H clock)
I set this up two days ago and it hasn't done a thing. Dell already applied the patch that fixes the issue with it not displaying which computers it's deployed to. We've already ran a successful File Synchronization with something else but now I can't get it to work. We're on K1000 Systems Management Appliance v5.3.45497 and looking to upgrade to the latest next week but this should work now.

Please help.
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1
This is a known issue. A zip file will not unzip via File Sync with latest 5.3. You can send down a zip file using an offline script that runs at check-in to achieve the same effect.
Answered 10/22/2011 by: GillySpy
Seventh Degree Black Belt

Please log in to comment
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Ok, I just did a manually upgrade on the server to version 5.3.47927so maybe it will work now?
Answered 10/24/2011 by: lefttunknown
Orange Belt

Please log in to comment
0
5.3.47927 was the last on Oct 23rd when I posted so it should still be broken in that build.
Answered 10/24/2011 by: GillySpy
Seventh Degree Black Belt

Please log in to comment
0
ya the file sync still didnt work last night. we were able to successfully get the zip folder to send and unzip during the day to a group of PCs but I am not sure why it wont work during my time frame. I created a custom build of adobe reader with patches using the adobe customization tool and unfortunately the entire zip folder is 54MB - too big to deploy during the day. Anyway, Can you explain more on how to use an offline script to send this file and unzip it?
Answered 10/25/2011 by: lefttunknown
Orange Belt

Please log in to comment
0
There is a task called "unzip a file" in a script. Just add your file as a dependency to the script.
Answered 10/25/2011 by: GillySpy
Seventh Degree Black Belt

Please log in to comment
0
awesome. one more question: I understand what I should enter for the target field (where the file should be unzipped to) , but what should I enter for File and Directory?
Answered 10/25/2011 by: lefttunknown
Orange Belt

Please log in to comment
0
Directory and File are what you are unzipping. So if yourzip.zip is a dependency then something like this:

Directory=$(KACE_DEPENDENCY_DIR)
File=yourzip.zip
Target=c:\destination
Answered 10/25/2011 by: GillySpy
Seventh Degree Black Belt

Please log in to comment
0
For us, File Syncs are working, however when the Zip gets extracted it doesn't keep the folder structure. All files just get extracted to the path directed and all subfolders inside the Zip get ignored.
Answered 10/31/2011 by: Arcolite
Senior Purple Belt

Please log in to comment
0
Arcolite, that is a known issue with using File Syncs right now.
Answered 10/31/2011 by: GillySpy
Seventh Degree Black Belt

Please log in to comment
0
Is there any ETA on a fix for this or should I just convert my File Syncs to Scripts (as above)?
Answered 10/31/2011 by: Arcolite
Senior Purple Belt

Please log in to comment
0
I do not have an ETA, but am working on getting one, if you open a support ticket I can keep you abreast of a bug fix a little better and tie your situation more strongly to the report.
Answered 10/31/2011 by: GillySpy
Seventh Degree Black Belt

Please log in to comment
0
Hi Gerald,

I already have a support ticket open reguarding some of the issues I'm having with 5.3.
It's ticket 166309.
Answered 11/01/2011 by: Arcolite
Senior Purple Belt

Please log in to comment
0
ORIGINAL: GillySpy

Arcolite, that is a known issue with using File Syncs right now.


FYI: Bug K1-10026
Answered 11/14/2011 by: need2mod
Senior Yellow Belt

Please log in to comment
0

Is there an update to version 5.3.53053 that fixes this issue?

Answered 10/01/2012 by: bwilkerson
Third Degree Brown Belt

Please log in to comment
Answer this question or Comment on this question for clarity