I just installed the current K1000 Trial on a virtual machine, but I cannot seem to access the \client or \clientdrop shares after activating the file share in the Security Settings section of the Administrator control panel. Every time I attempt to do so, I get a message saying "An unexpected network error occurred."

Here is what I have tried:
- Tried with and without NTLMv2 support.
- Opened up Windows Firewall for Network Discovery and File & Print Sharing on the "host" computer.
- Attempted to log into the shares with both the DNS name and the IP address.
- Completely turned off Windows Firewall on the client side.

Occasionally I get a login prompt for the \clientdrop share, but despite entering the proper username and password, all roads eventually lead to "An unexpected network error occurred." The Event Viewer in Windows does not lead to any additional insight about the problem.

I went into the Troubleshooting Tools and attempted to run smbstatus, but I get the following error:
ERROR: Failed to initialise messages database: Permission denied
messaging_tdb_init failed: NT_STATUS_ACCESS_DENIED
messaging_init failed
using configfile = /usr/local/etc/smb.conf

I have no idea what I am doing wrong.
1 Comment   [ + ] Show Comment

Comments

  • I know this is an old post - but these settings worked and then they don't. So what is the secret It's not group policy, because even my workstation not assigned to the domain cannot access it. But My dc's can.
Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
It Looks NTLM related issue, Have you tried disabling NTLM on your Windows machine.

Setting required on Windows machine

Control Panel - Administrative Tools - Local Security Policy
Local Policies - Security Options
Network security: LAN Manager authentication level , change value to
Send LM & NTLM responses
Minimum session security for NTLM SSP
Disable Require 128-bit encryption

Setting Required on Kbox
Select Settings/Control Panel
Select Security Settings
Select Enable File Sharing and set the File Share User ‘admin’ Password
Answered 05/12/2011 by: afzal
Fourth Degree Green Belt

  • thanks for the post! I missed the password setting in the kbox control panel but now its all good.

    Setting Required on Kbox
    Select Settings/Control Panel
    Select Security Settings
    Select Enable File Sharing and set the File Share User ‘admin’ Password
Please log in to comment
0
My organization's Group Policy currently mandates that our machines require NTLMv2 session security and 128-bit encryption. We tried activating the options "Require NTLMv2 on K1000 File Shares" and "Require NTLMv2 on K1000 Samba Client Usage," which we figured would make the K1000 perform transactions at that level. Is the K1000 capable of using NTLMv2 and 128-bit encryption? If not, is there a timetable for when it will? It would be very difficult for me to get Group Policy security settings downgraded.
Answered 05/12/2011 by: gpcz
Senior Yellow Belt

Please log in to comment
0
Hummm! are you trying to access 'Client Drop' or 'Client' ? I am able to access client without any problem.

However, in NTLM v2 environment ,enabling NTLMv2 option in Kbox does not provide me the required access .

Just to isolate the problem , You can try it on some test machine which is not the part of your domain.
Answered 05/12/2011 by: afzal
Fourth Degree Green Belt

Please log in to comment
Answer this question or Comment on this question for clarity