Hello,

I have the following problem. I have created a patch (minor) that updates a license string and a couple of files and keeps the version the same. When I install the base application and the patch from a command line with administrative rights the patch works fine, however when I distribute the patch in SMS 2003 I receive the following error: "The system administrator has set policies to prevent this installation". In SMS the application is installed on a per user base with command line: msiexec.exe /i <application> ALLUSERS="" /qr. The patch is installed with command line: msiexec.exe /p <patch> ALLUSERS="" /qb

There are no policies set.The patch is created with Wise Package Studio 7 SP2 by using the patch creation tool.

Anyone have an idea what could be the problem?

Thanks,
Robin
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Make sure the following is not set to 2, change it to 0 and the error should go away.

DisableMSI
If the value of this per-machine system policy is set to "2" the installer is always disabled for all applications. If this policy value is set to "1", the installer is disabled for unmanaged applications but is still enabled for managed applications.


The following table lists the possible configurations.

DisableMSI Description
Default On Windows Server 2003 family, if the policy value is Null, absent, or any number other than 1 or 2, the Windows Installer is enabled for managed applications. Unmanaged application installs are blocked.

0 Windows Installer is enabled for all applications. All install operations are allowed.
1 The Windows Installer is disabled for unmanaged applications but is still enabled for managed applications. Non-elevated per-user installations are blocked. Per-user elevated and per-machine installs are allowed.
2 Windows Installer is always disabled for all applications. No installs are allowed including repairs, reinstalls, or on-demand installations.

Registry Key

HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\
Windows\Installer

Data Type
REG_DWORD

DisableMSI = 2
Answered 07/16/2007 by: Burner
Senior Yellow Belt

Please log in to comment
0
Hi guys,

I am getting the same error with VMWare. My problem is that I can't find DisableMSI under HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\Installer

Please help
Thanks
Answered 06/19/2008 by: MexicoBoy
Yellow Belt

Please log in to comment
0
Run the install with ProcMon running alongside. Filter out the junk you're not interested in (e.g. Explorer.EXE, SVCHOST.EXE and so on). When the error appears, stop ProcMon's processing, then check the output for entries with the result 'NAME NOT FOUND' or 'ACCESS DENIED'. One of them will be the culprit.
Answered 06/19/2008 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity