Trying to push Adobe Reader 8.0 with an MST that changes a few things. The package installs on about 90% of machines. The rest come back with the error message "Error Applying Transform. Verify that the specified transform paths are valid." I've tried installing the lastest version of Windows Installer but still receive the error message. I have logging turned on and below is the error message in the log:

DEBUG: Error 2759: Transform C:\WINDOWS\Installer\42afc7d.mst version 301 incompatible with engine; Min: 30, Max: 300.

Anyone have any ideas?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
How did you create the MST?
Answered 04/25/2007 by: JdotQ
Senior Purple Belt

Please log in to comment
0
Check {HKEY_CLASSES_ROOT\Installer\Products\68AB67CA7DA73301B7448A0000000020}
Delete "TRANSFORMS" if it exists and try again..

I'm not sure of your exact error - don't know if I've ever seen that before, but this is a place to start.

If you release a package and then release an "upgrade" package (comparable to a package that has an MSP applied to it) that has components missing that were in the orginial package, and also that the transform references will cause an error like this.

It's the end of the day, and i'm might be rambling, but I hope this helps out somewhat...

-Grant
Answered 04/25/2007 by: gmorgan618
Blue Belt

Please log in to comment
0
sounds like you or the original MSI is windows installer 3.x where your machines may not be.

seems a little odd this wasn't flagged earlier.

whats the status of the target workstation ?

xp sp ?
Answered 04/26/2007 by: jmcfadyen
Fifth Degree Black Belt

Please log in to comment
0
ORIGINAL: dpolishsensation

DEBUG: Error 2759: Transform C:\WINDOWS\Installer\42afc7d.mst version 301 incompatible with engine; Min: 30, Max: 300.

Anyone have any ideas?


Your target machine has MSI Installer 3.0 (XP SP2 Standard)
Your target machine needs: MSI Installer 3.1 (KB893803)
Answered 05/07/2007 by: KPrinz
Fourth Degree Green Belt

Please log in to comment
0
Old thread, but still.
I know transforms is a public property. But there´s no problem installing a package with a command like e.g:
"msiexec.exe /i msiname.msi Transforms=mstname.mst /qb
on a Win XP or Win 7
So, when does any problems arise for using "Transforms=" instead of "TRANSFORMS="?
Answered 12/22/2011 by: zzpack
Orange Senior Belt

Please log in to comment
4
[quote]So, when does any problems arise for using "Transforms=" instead of "TRANSFORMS="? [/quote]WHO CARES?!? Just make it all upper-case every time you use it. How hard is that?
Answered 12/22/2011 by: VBScab
Red Belt

Please log in to comment
-4
Obv I care.
And a merry fuc*ing x-mas to you Scrooge.
Answered 12/23/2011 by: zzpack
Orange Senior Belt

Please log in to comment
Answer this question or Comment on this question for clarity