I'm trying to repackage Logitech Image Studio 7.3 using Wise for Windows Installer 5.1 Professional.

After running the setup capture and compiling it when i run the .msi i get an internal error 2705 and then it bombs out.

Has anyone had this same error before when repackging an application and if so what are the general areas to look at to fix the problem?

Cheers

Dave
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
I've been slowly populating a database for describing and dealing with Windows Installer Errors at http://www.appdeploy.com/faq/msi_errors/index.asp

For Error 2705 we have,

Are you authoring an MSI where you are linking to DLL files? If so, ensure the correct version of the DLL exists on your target system. You may also try linking to the DLLs statically vs. dynamically or dynamically vs. statically (as the case may be.)
Answered 07/07/2004 by: bkelly
Red Belt

Please log in to comment
0
Couple things to try, make sure that the reference machine is a clean image. Also, just for kicks, try and repackage it with Wininstall LE 2003. See if you get the same result, it may just be a deficiency of Wise.
Answered 07/07/2004 by: cdupuis
Third Degree Green Belt

Please log in to comment
0
Just took a quick look at the logitech software and if you extract the contents of is730enu.exe there is a folder called Appinst. This contains the Windows installer version of Image Studio 7.3. This might help in deploying it, do not repackage it and just create a Transform file.
Answered 07/07/2004 by: cdupuis
Third Degree Green Belt

Please log in to comment
Answer this question or Comment on this question for clarity