I'm trying to packaging this app using ....while compiling getting error Error 1911. Could not register type library ? Any suggestion... why it's doing that
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.



A file is set to self-register when it should be set to Extract COM Data.
A merge module being used is incorrectly authored.
A file is corrupted or not installed.


Extract COM data instead of using self-registration

For Express users:

(1) Select the Files view and find the file that was displayed in the error message. You may need to search multiple features and folders within the Files view to find the file.

(2)Once the file is found, right-click it and select Properties.

(3) Select the COM and .NET Settings tab.

(4) In the Registration Type drop-down field, select the Extract COM Information option.

For all other users:

(1) Select the Setup Design view and find the component that contains the file displayed in the error message. Make sure that you find the specific component and not just the feature that the component is associated with.

(2) If there is more then one .dll, .ocx, .tlb, .olb, or .exe in this component, create a new component for each extra file under the same feature. Use the following steps to create a new component:

(a) Right-click the feature and select New Component.

(b) In the new component node, select Files.

(c) Add a file by right-clicking in the Files pane and selecting Add.

(d) Right-click the file and select Set Key File.


Determine if a merge module is causing the error by deselecting groups of merge modules in your project, building, and running the installation until the error no longer occurs. Once the error no longer occurs, continue to narrow down to the exact merge module causing the error by repeating the process with the merge modules that were removed. If the error still occurs after deselecting all modules, try solution A.

Once you have determined the merge module causing the problem, determine if this is a third-party merge module or a merge module you created.

If it is a merge module you created, try solution A within your merge module project.

If the module is a third-party module, verify that you have the latest version of the module. Merge modules that are distributed with the InstallShield product can be downloaded from the merge module gallery. If the merge module causing the error was not distributed with InstallShield, check for the latest version on the vendor's site.

Install the latest version of MDAC and Jet

Retrieve the downloads for the latest version of MDAC and Jet from the Data Access and Storage Developer Center.

Install these updates manually on the trouble machine.

Rerun the installation.

If the file already exists on the machine, rename it

Check to see if the file displayed in the error message is already on the target machine. This can be determined by doing a search for the file name using the Windows Search tool on the Start menu.

Rename any instances of the file by adding the extension .old to the file name, e.g., file.exe.old.

Rerun the installation.

If running from a CD, manually copy it to local drive

If the installation is running from a CD, copy the installation from the CD to a location on the local drive.

Rerun the installation.

I hope this information was helpful!
Answered 05/17/2006 by: grambarose
Yellow Belt

Please log in to comment
Never had that problem before or even had much dealings with .tlb (think they are type libs) but did you try deleting from your project (take a good copy of it first of course).

Then re-add using the component wizard (if using installshield - uncheck "extract during build.." during the wizard) this way it should register it during the addition to the project..... long shot but worth a try - should only take 5 mins!
Answered 05/17/2006 by: islander222
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity