I've almost finished my transform for this app. No problems with getting it to install or the CA that runs install.exe.

I'm having trouble applying properties ARPNOREMOVE, ARPNOMODIFY, ARPNOREPAIR. They don't apply correctly through MST, via commandline or even when I change the registry settings under :HKLM\Software\Microsoft\Windows\CurrentVersion\Uninstall\{product key}

The ARP stuff just appears as the default, showing the buttons I want to hide!!

Any Ideas?

D
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1
I had the same issue, The thing with this one is it two apps, one is hidden in the add remove panel, so when you try the above it add the ARP values to the hidden one , what you to do is add the following entries into the registry table:

reg1010 2 SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Microsoft .NET Framework 2.0 NoRemove #1 SBSCMP10_DLL_____X86.3643236F_FC70_11D3_A536_0090278A1BB8
reg1011 2 SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Microsoft .NET Framework 2.0 NoModify #1 SBSCMP10_DLL_____X86.3643236F_FC70_11D3_A536_0090278A1BB8
reg1012 2 SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Microsoft .NET Framework 2.0 NoRepair #1 SBSCMP10_DLL_____X86.3643236F_FC70_11D3_A536_0090278A1BB8

and all should be fixed up
Answered 03/30/2006 by: Thariq
Yellow Belt

Please log in to comment
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
nice one thariq.

couldnt find any info about that anywhere.
Answered 04/03/2006 by: dm1
Blue Belt

Please log in to comment
Answer this question or Comment on this question for clarity