I'm trying to create a package for Firefox 4.0.1 in which I need to disable the installation and use of any add-ons if this is possible.
I know you can disable add-ons in safe mode but I can't find anywhere in the config files where I can completely disable them, because even after disabling in safe mode you can re-enable using Tools > Add-ons.

I've thought about removing the Add-ons menu in Tools, but can't figure out how to. I can remove the Tools menu by placing a text file called userChrome.css to the profile path with the following inside:

#tools-menu { display: none !important; }

Anyone out there know how to manipulate this to include the Tools menu, but exclude the Add-ons menu item?

Even better, anyone know how to disable the use of add-ons completely through config files?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

2
Have you read the 'Package KB' Notes section? IIRC, most of what works in v3.x still works for v4.x.
Answered 05/26/2011 by: VBScab
Red Belt

Please log in to comment
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Thanks a lot VBScab. Sorry I'm new here and didn't look around enough before posting as I was trying to get out of the office yesterday afternoon. Thanks for the reply and I'm having a look through there but it doesn't seem anyone on here or anything I can find through google can tell me how to do this. I'll keep trying and let you guys know if I figure it out.

I'm talking with some support guys now so hopefully we'll be able to get all add-ons disabled.
Answered 05/26/2011 by: Gut
Yellow Belt

Please log in to comment
2
Have a search for Firefox and locked preference files, a good link to start with is http://kb.mozillazine.org/Locking_preferences. Once you understand the basics the preference you want to set is:

lockPref("xpinstall.enabled", false);

I've packaged / customised firefox since 2.x for a very locked down setup, if you have any questions post back and i may be able to help.

As you noted you have to hide the option via the userChrome.css file.
Answered 05/27/2011 by: dodgy
Orange Belt

Please log in to comment
0
DODGY! You have solved my issue!! Thanks so much, I'd tried disabling the xpinstall.enabled option through about:config however it did nothing. But now that you've told me to use lockpref it's working a treat. You've just saved me a lot of trouble my friend, I owe you!
Answered 05/29/2011 by: Gut
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity