Hello.

I work at a Netbeans-package. My problem is to disable the "UsageStatistics". I've found the properties for this feature in the file core.properties. This file will be created at the 1. start of the Netbeans-IDE. At the second start of the IDE, a window pops up which want you to take part in a UserStatisticsProgram. 

 

I've tried to put a customized file in the same direction, but at the 1. start Netbeans overwrite the existing file.

 

Is there any way to disable the "usageStatistics"-Window?

 

 

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

0

Hello SMal.tmcc,

 

thank you 4 your answer. Sadly, the hints in your link, doesn't work for me.

There are too many dependancies between the modules of netbeans, so its not safe enough to simply disable that module. That workarround is recommended for Netbeans (Module)-Developer which want to test their own modules or for IDE tweaking purposes.

(Sorry for my bad english - I'am not a native speaker/writer)

So it seems, there is no way to disable that behavior for wide-deployment of netbeans IDE.

 

Answered 01/24/2013 by: t4a
Senior Yellow Belt

  • They like to get those numbers so they can brag how many users they have for netbeans
    01.# Country Count Ratio

    02.1. United States 373,252 16.1%

    03.2. Brazil 204,470 8.8%

    04.3. India 142,460 6.1%

    05.4. Germany 120,482 5.2%

    06.5. China 117,489 5.1%

    07.6. Mexico 88,320 3.8%

    08.7. United Kingdom 79,847 3.4%

    09.8. Spain 78,408 3.4%

    10.9. Italy 65,798 2.8%

    11.10. France 59,191 2.5%

    12.11. Poland 57,076 2.5%

    13.12. Canada 49,666 2.1%

    14.13. Colombia 42,970 1.8%

    15.14. Japan 40,883 1.8%

    16.15. Peru 37,230 1.6%

    17.16. Czech Republic 32,763 1.4%

    18.17. Russian Federation 29,765 1.3%

    19.18. Australia 27,992 1.2%

    20.19. Thailand 27,975 1.2%

    21.20. Netherlands 24,551 1.1%
Please log in to comment
0

http://forums.netbeans.org/ptopic40086.html

Answered 01/22/2013 by: SMal.tmcc
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity