Hi all,

I'm in the process of packaging Java 6 update 30. I want to disable auto-update and also ensure that in the Java control panel the option under the advanced tab "JRE Auto-Download" is set to "Never Auto-Download". It looks like this setting is stored in the deployment.properties file which is stored in the "%username%\appdata\locallow\sun\java\deployment" folder. Specifically the line is "deployment.javaws.autodownload=NEVER".

I have tried adding this file to my transform and using active setup to ensure it gets copied to each users appdata area on login. However, it seems Java creates it's own default deployment.properties file once you install the program. Has anyone come across this? Any suggestions?

I have set the following properties in my transform

AUTOUPDATECHECK=0 IEXPLORER=1 JAVAUPDATE=0 JU=0 MOZILLA=1 SYSTRAY=0

I've also added the following registry keys to my transform

"HKLM\SOFTWARE\JavaSoft\Java Update\Policy" /v EnableJavaUpdate /t REG_DWORD /d 0 /f
"HKLM\SOFTWARE\JavaSoft\Java Update\Policy" /v EnableAutoUpdateCheck /t REG_DWORD /d 0 /f
"HKLM\SOFTWARE\JavaSoft\Java Update\Policy" /v NotifyDownload /t REG_DWORD /d 0 /f
"HKLM\SOFTWARE\JavaSoft\Java Update\Policy" /v NotifyInstall /t REG_DWORD /d 0 /f

Rgds,
Mark
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Mark,

I tend to put a system-wide deployment.config file in my JRE packages. Its supposed to go in the folder
<Windows Directory>\Sun\Java\Deployment\
Then I put the deployment.properties file in the same folder and point to it in deployment.config. For one, no messing about in the user profiles..

Have a look here for an overview of the principles involved.

Kr,
PJ
Answered 02/20/2012 by: pjgeutjens
Red Belt

  • What I am wanting to do is put the deployment.properties file on a server so if I want to make changes to it I won't have to copy it to all the computers again. In version 6 that worked great but in version 7 it ignores the deployment.config file for the system and makes a user one if the Control Panel is opened.
Please log in to comment
0
Yup, me too.
Answered 02/20/2012 by: VBScab
Red Belt

Please log in to comment
0
Hey guys,

I've done that and it works a treat! Thanks very much for your help!

Rgds,
Mark
Answered 02/20/2012 by: mark_holland21
Fourth Degree Green Belt

Please log in to comment
0
Hi all,

I have tried the above mentioned method to disable the auto-update for Java(TM) 7 Update 1 (64-bit) application and I am not lucky with this.Because its not working to me.

I am not able to find the deployment.config file in windows directory or appdata.

Deployment.config file is not available in any part of the system.

I am able to get deployment.properties in the following location C:\Users\Windows 7 64 Bit\AppData\LocalLow\Sun\Java\Deployment after clicking the java from control panel.

So please can someone help me to disable the auto-update of this application and make this package is done as soon as possible.

Looking for answers from you techies.



Thanks.
Answered 02/20/2012 by: dhanraj
Senior Yellow Belt

  • This is where the update options are in the registry.
    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\JavaSoft\Java Update\Policy]
Please log in to comment
0
A little quote from the link I posted earlier:

The deployment.config file is used for specifying the System-Level deployment.properties in the infrastructure. By default no deployment.config file exists; thus, no system-wide deployment.properties file exists
So you need to make your own and put it in the path I mentioned.

Kr,
PJ
Answered 02/21/2012 by: pjgeutjens
Red Belt

Please log in to comment
0
Hi ,

Thank you.

I am a just six month baby in packaging .So I am not aware of how to create the deployment.config file.

Can you please help me to create the deployment.config file or if you any code please share me.

Really I am looking forward to hear from you.

Many thanks in advance.
Answered 02/21/2012 by: dhanraj
Senior Yellow Belt

Please log in to comment
0
Dhanraj,

read the link that I posted in #2 and have a look here for some more info.

Kr,
PJ
Answered 02/21/2012 by: pjgeutjens
Red Belt

Please log in to comment
0
Hi PJ,

Yes,Its working excellent for me and very much thanks.

Hope will hear from you lot in future.

Many thanks.
Answered 02/21/2012 by: dhanraj
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity