Hi,

I have downloaded the entreprise msi for Google Chrome (ver 65.39.77).

Even though there are GPO's to disable updates etc, by the time the policies are present on the machine, some machines will have had Google Chrome update itself due to services\task schedule.

I need to disable the services (2 of them) and disable the task schedule (2 of them).

The serices\task sequences are not mentioned in the MSI.

What methods are people using to stop Google Chrome from updating itself via services\task sequence? I did a snap shot of  manually disabling these, when I install the MSI it does successfully disable the services but it seems to corrupt the task sequence, rather than disabling them.

Thanks...  

0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

1

Have you tried installing it with the property "NOGOOGLEUPDATING=1"? That worked for me, but I'm not sure what Chrome version I used.

Answered 08/15/2012 by: andemats
Second Degree Black Belt

Please log in to comment
1

The auto updates can be disabled via registry.

Create a transform with the registry change HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Update
Add a new DWORD value named DisableAutoUpdateChecksCheckboxValue and set it to 1 to disable automatic updates.

Answered 08/15/2012 by: SnowLyric
Second Degree Brown Belt

Please log in to comment
1

Thanks for your replies. I have added:

Properties:

NOGOOGLEUPDATING=1

NOGOOGLEUPDATPING=1

Also added the following 2 reg keys to disable the 2 services:

HKLM\SYSTEM\CurrentControlSet\services\gupdate DWORD value named Start with value of 4

HKLM\SYSTEM\CurrentControlSet\services\gupdatem DWORD value names Strat with value of 4

Even though these disable the services, when the task schedule runs it re-enables the service.

To disable the Task Schedule I have added the following:

HKLM\SOFTWARE\Policies\Google\Update new DWORD value DisableAutoUpdateChecksCheckboxValue and set it to 1

HKLM\SOFTWARE\Policies\Google\Update new DWORD value named UpdateDefault and set it to 1

I found without the last registry key (UpdateDefault and set it to 1) it didn't disable updates.

This seems to have worked but I'm still testing... The next test wil lbe to delete c:\program files(x86)Google\Update\googleupdate.exe. The reason I want to try this is because the task scheduler still runs every hour and tries to update, but as updates are disabled it doesn't appear to be successfull. I would rather the task schedule not run every hour.

Thanks again for your replies.

Answered 08/16/2012 by: Meic
Second Degree Blue Belt

Please log in to comment
1

Instead of deleting googleupdate.exe I just created a GPO to delete the task schedule and also 2 GPO's to disable the 2 services.

So the MSI takes care of disabling the updates, and then the policies take care of deleting\modifying 'Task Schedule' and 'Services'.

Cheers.

Answered 08/27/2012 by: Meic
Second Degree Blue Belt

Please log in to comment
Answer this question or Comment on this question for clarity

Share