I'm trying to deploy Adobe Acrobat Reader DC with SCCM 2012 R2 and I am having a difficult time with respect to file associations.

I have tried deploying using both the setup.exe and the msi file as an application.

On both a Windows 10 machine and a Windows 7 machine Reader deploys to the machine without issue and even appears to use the custom transform file that I created with the Adobe Customization Wizard. However, I can't get it to take over as the default application for pdf files.

With multiple test deployments on the same machines the results are never consistent. 

What I experience is, Reader deploys fine (installs), sometimes it takes the file association but either leaves the icons for pdf files white or with the icon of the application previously set as the default. Double-clicking on the files opens them in Reader, after a reboot, the icon changes to Reader.

Other times (most of the time) the file association is left to the previous application or not taken over at all if there was no association to begin with. For example Microsoft Edge or just a blank icon because there was never an app associated.

And a few times, opening Reader fater the deployment would prompt me to make it the default. This works but is annoying and either way, the results are not consistent.

How are people deploying Reader DC with SCCM, with details, and having it handle taking over as the default application? At the moment it seems to me that I would have to deploy a script after the software installs to force it.

Any help would be appreciated.

Thanks!
0 Comments   [ + ] Show Comments

Comments

  • This content is currently hidden from public view.
    Reason: Removed by member request
    For more information, visit our FAQ's.
Please log in to comment

Answers

0
I wonder if all of the possible properties in the MST have been set, particularly,OWNERSHIP_STATE? See here for details.
Answered 05/06/2016 by: VBScab
Red Belt

  • I tried using the OWNERSHIP_STATE=2 option as well. No change.
    • I’d be interested in the outcome. I’ve found setting FTA in Windows 10 really problematic, not as easy as it used to be in Windows 7. Sorry comments not really helpful for you (:

      Auctually we have this packaged, let me deploy it and I will report back.
      • Thanks. It appears to behave the same way on both Windows 10 and Windows 7.
      • I successfully deployed to a Windows 7 machine that had Reader 10 installed and it uninstalled 10, replaced it with DC and associated pdf files with Reader DC. The same deployment went to a Windows 10 machine with no reader installed and it installed successfully but did not take ownership of the pdf file association. It left Microsoft Edge as the default program and when Reader DC was opened, it prompted the user top make it the default application for pdf files.
      • Ugh, just realised that I created the package not to take ownership - useless test to report back with, sorry.
      • I tried switching to a package as opposed to an application and same results, it deploys but doesn't modify the file associations correctly.
      • You have diff issue below, see below for more details.

        >>The same deployment went to a Windows 10 machine with no reader installed and it installed successfully but did not take ownership of the pdf file association. It left Microsoft Edge as the default program

        Dont know how to resolve this in our env we want Edge to be the default.



        >>and when Reader DC was opened, it prompted the user top make it the default application for pdf files.

        You can resolve this by creating a GPO to suppress this dialog, note its in the HKCU path. I googled a bit but I couldnt find a ADMX or setting in the installer to turn off the nag.
        [HKEY_CURRENT_USER\SOFTWARE\Adobe\Acrobat Reader\DC\AVAlert\cCheckbox]
        "iAppDoNotTakePDFOwnershipAtLaunch"=dword:00000001
Please log in to comment
0

>What I experience is, Reader deploys fine (installs), sometimes it takes the file association but either leaves
>the icons for pdf files white or with the icon of the application previously set as the default. Double-clicking on
>the files opens them in Reader, after a reboot, the icon changes to Reader.

Ah...wait...You seem to be saying that, while double-clicking a PDF does indeed open it in Reader, the file's icon in Explorer doesn't reflect its association? If that's all it is, I'd strongly suspect failure of the old Windows feature, the icon cache.

Answered 05/06/2016 by: VBScab
Red Belt

  • It isn't that simple though unfortunately. The way it handles the file associations isn't consistent. Sometimes it behaves in that manner where the association exists and the icon doesn't change but just as many times in my testing it doesn't change it at all... and sometimes when it doesn't change it, it prompts the user to make it the default after launching reader. This doesn't really make me confident that when I deploy it on a larger scale that it will work as expected.
  • Could this possibly have something to do with UAC or not running with elevated privileges?
Please log in to comment
0
Starting a new answer to make things easier to read.

Right, good news in Im in your boat now! I have been tasked with making Reader the default PDF handler.

SCCM 2012 R2 deploying Reader DC via the setup.exe with modded setup.ini (so it uses the mst created with Adobe Cust Tool, then patches as per normal)

Test Cases

  • Install via Admin account.
    PDF handler is with Reader (icon change from edge to reader)
    Did not launch Reader.

  • Logged into pre cached account.
    PDF handler is with Reader, pdf opens fine.
    If you switch PDF handler to Edge and open with Reader - you will get prompt to set Reader as the handler, this will prompt a UAC call, I cancelled out.

  • Logged in with fresh, non cached account.
    PDF handler was with Edge (not Reader as expected), pdf opens fine in Edge
    If you open with Reader - you will get prompt to set Reader as the handler, this will prompt a UAC call, I cancelled out.


Please note that the default PDF handler and Reader asking to set itself as the default pdf handler are two diffent issues.

Unresolved:
Setting PDF handlier to Reader for all users and new users.

Resolved:
You can suppress Reader from asking to be the default handler as mention above by setting a GPO for the registry key [HKEY_CURRENT_USER\SOFTWARE\Adobe\Acrobat Reader\DC\AVAlert\cCheckbox]
"iAppDoNotTakePDFOwnershipAtLaunch"=dword:00000001"




Thoughts
I have a feeling OWNERSHIP_STATE does not work with Windows 10, humm that's probaly a bad statement, I should say the way Windows 10 sets handlers may have changed which will effect how OWNERSHIP_STATE is implemented. Adobe's documentation states that when this property is set to 2 it will "Take ownership for all existing and new users". W





Answered 05/16/2016 by: rileyz
Red Belt

  • My experience is slightly different. I also use setup.exe but I don't use any special setup.ini, just the one that is there after I use the customization wizard to make my mst/package. My mst gets applied simply by launching setup.exe.

    the default PDF handler behaves in the ways I mentioned above.

    Are you deploying as a package or an application? do you use any scripts are part of your deployment?

    Thanks!
  • I tested deployment again this time with a forced restart from SCCM and on the windows 10 machine it set the file associations after the reboot. I will try it with a Windows 7 machine today and see if it behaves the same way. If it does, then a reboot is the answer.
  • So that seems to be the solution. Deployment to windows 10 and windows 7 machines was a success and forcing a restart via sccm took care of setting the file associations for pdf files to reader dc. Thanks.
    • We use an application in our org. Good to know about the reboot, I'll try that out on our Windows 10 build and let you know how I get on.
    • I just tested yesterday with a Reader deployment, the install of reader was set to take ownership of the PDF files. In testing we found that cached accounts has the pdf handler set to Reader, BUT new accounts on the machine would have the reader set to Edge. Still an on going issue for us on Windows 10.
Please log in to comment
Answer this question or Comment on this question for clarity

Share