I am looking to deploy Lync 2013. I have created the .MSP file and placed it in the Updates folder and zipped the package up to Kace.

I have tried running the parameters of:

setup.exe

setup.exe /S

setup.exe /Silent

setup.exe /adminfile "Updates\LyncInstaller.MSP

 

None of which works. Any help would be helpful.

Answer Summary:
See paul.theelen's answer
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

1

The last option should work though but there is an error in the last command it seems.

You added a double quote before the path and none after it.

The quotes are not needed unless you use spaces in them.

 

As it is a Microsoft Product it should work the same.

This is an example I used for project.

setup.exe /adminfile MSProjectProfessional2010.MSP

 

Hopefully this KB will help you:

http://technet.microsoft.com/en-us/library/jj205129.aspx

Answered 02/20/2013 by: paul.theelen
Orange Senior Belt

  • Thank you @paul.theelen That worked. :) Typo
    • Yeah always helps if someone take a second look :)
  • @akilpatrick. I am trying to deploy Lync 2013 as well. Did you set this up as a script or as a managed install? Will you please respond with specifics on how you set this up. It would really help me out.
  • I used a managed install to accomplish this. I followed the article here: http://technet.microsoft.com/en-us/library/dd630736.aspx

    Under the section "Use the OCT to a configure silent installation and automatic activation"

    Open the command prompt in the folder where setup.exe is and run setup.exe /admin to start your customization file that the installer will read at installation. Then I zipped the folder and uploaded to the k1000 and deployed using configure manually with the parameters of: setup.exe /adminfile Lync2013Install.MSP


    I hope this helps.
  • I'm still not having any luck, I made the msp file and put it in the updates folder and zip it and associated the zip file to the deployment. When I pull the files out of the iso image I have an x64 folder, x86 folder, autorun.inf file, setup.dll, and a setup.exe. In both the x64 and x86 folder there are different sets of office folders (admin, catalog, lync.en-us, lync.ww...) as well as another setup.exe file. I have tried running with both the x64 and x86 files in the zipped folder and I have tried to run it with only the x86 files. What files did you contain in your zip?
  • I ran the setup.exe in the x86/x64 folders. I created to separate installers. I created the .MSP file placed it in the updates folder and within the setup.exe and all the other folders (root of the folder). May not make a difference to have the same MSP file in two places, but thats what I did and it worked. I then selected all the files within the x86/x64 folder and zipped it and uploaded to Kace. Let me know if this helps. Hope it makes sense.
  • I started poking around on my test system to see if 2013 lync is there because, everything says that it ran successfully. On the local drive c:\ProgramData\Dell\Kace\kbots_cache\packages\188 it shows both the zipped and unzipped folders. I have the run parameter set as setup.exe /adminfile 2013Lync.MSP. Any ideas why it did not install?
  • Also, check in C:\ProgramData\Dell\KACE\downloads you should have the extracted installer there too.
  • Yes they are there too. Did you have your's automatically install on the systems?
  • I have tested on a test box. I have a scheduled deployment coming in a few weeks.
  • This has taken me further than I have been but, my ultimate goal is to get them to install silently. So your's did install on it's own then? Did you put /i in the command parameters? Thank you for all your input and responding back to me. I just don't understand why this one product is so difficult!
Please log in to comment

Answers

0

And I'm assuming you're using the Office 2013 installer mechanism.

 

What happens when you attempt to deploy? Have you checked logs?

Answered 02/19/2013 by: sccmskin
White Belt

Please log in to comment
Answer this question or Comment on this question for clarity