We are having a hard time getting our ISC DHCP server to allow clients to PXE boot.

We believe we don't have option 66 and option 244 set correctly.  (We haven't even been able to find any documentation on how to set option 244)

We've read numerous articles on this and still can't get it working.  Support was unable to help as well.

We are able to PXE boot a client and see the boot menu where we get the choice of the boot environments to boot into.  After this, we get a DOS acreen that errors after the kgetdhcp 66 and kgetdhcp 244 commands with "Unable to determine server IP address from DHCP, using hardcoded K2000 IP address as fallback."


We have already looked at the following URL's concerning this:







Answer Summary:
moved the config from the root to a subnet.
0 Comments   [ + ] Show Comments


Please log in to comment



looking at your link http://www.ipamworldwide.com/dhcp-options/isc-dhcpv4-options.html

you should be able to work with just options 66 and 67

use the ip of the k2000 for option 66

use  kbox2000.0 for option 67 (zero's)

Answered 09/25/2012 by: SMal.tmcc
Red Belt

  • should be
    option tftp-server-name (ip of k2000)
    option bootfile-name k2000.0
  • to setup option 244
    option k2000-option244 code 244 = (ip of k2000)
  • We tried both kbox2000.0 and k2000.0 for the bootfile name, same error.

    SMal I'll forward this to my DHCP guy and see if that is the way he has been trying option 244.
  • He's saying that is looks like you are missing half of the command from what you listed above for option 244. We have options 66 and 67 defined and it is still not working.

    There needs to be a text command, like what is listed on your link:
    Text type options specify values encoded as ASCII text strings.
    Declaration: option your-help-contact code 212 = text;
    Setting: option your-help-contact “John Smithâ€;

    He says there also needs to be something to define the option, which is missing from your command.
  • If option 66 and 67 are working you should not need 244.
    I reread that link and to create 244 it should be

    IPv4 Address Type Options

    The IP-address data type enables specification of an IPv4 address or resolvable domain name.

    Declaration: option our-file-server code 213 = ip-address;

    Setting: option our-file-server;

    option our-file-server fileserv1.ipamww.com;

    option kace244 code 244 = (ip of k2000)
    the name of the option is for yourself, the systems do not care
  • also as Ben mentioned check the nic by using a boot disk/stick from the same boot environment.
  • We got it working today. My coworker moved the config from the root to a subnet. He was using a packet sniffer and noticed when it was at root it wasn't showing options 66 and 67. When he moved it to the subnet it was.
  • you want it on a subnet level if you plan on rolling out RSA's, that way you can target a certain server based on subnet.
Please log in to comment

I also had set options 66 & 67 globally.  Since we have many subnets, I chose to keep the options global and add option 244:

option k2000-option244 code 244 = ip-address;
option k2000-option244;
filename "kbox2000.0";

This ultimately worked for us.  PXE boot finds 66 & 67, then the WinPE boot fails-over to the 244.


Answered 11/09/2012 by: njd
Senior White Belt

Please log in to comment

I'd like to point out that the only time I've ever seen this error is when I don't have the correct nic drivers installed in the KBE for the machine I'm working with.

Answered 09/25/2012 by: Ben M
Ninth Degree Black Belt

  • Hi Ben,

    I was worried about the NIC drivers too, as I was initially trying this on a Optiplex 990 which is pretty new. I switched over to a Optiplex 755 which I figured is old enough to have the NIC drivers for it built in to KACE. Same error with both systems.
  • create a boot disk from your boot environment. does it work? if yes you have the correct drivers.
Please log in to comment
Answer this question or Comment on this question for clarity