Client is  ampagent-6.4.180-x86.  I am able to manually install the client.  I enter the fqdn of the kbox.  Client installs but does not check in.  I can ping the kbox from the client.  I can get to the web address of the kbox in two different browsers on the client.  I am able to get the client to show up in KACE by running runkbot 4 0 from the command line of the client, but after it shows up, I can't force an inventory from the admin console.  Firewalls are off.
Below is the output of what happened when I ran runkbot 4 0.  I highlighted some of the strange parts that seem to be causing a problem.  We have other Windows 10 computers that are working fine with KACE and I don't know why this is happening.

Thanks for any help you can provide.

Jeff

 C:\windows\system32>cd C:\Program Files (x86)\Dell\KACE

C:\Program Files (x86)\Dell\KACE>runkbot 4 0
[2016-05-13.16:04:27][runkbot:GetKbot                 ] Kbot [4-0] not found locally, downloading ...
kbot[4:0] @ 2016-05-13T16:04:27 (status) START
[2016-05-13.16:04:27][runkbot:DownloadDependency      ] Downloading dependency from KBOX location [https://kbox.smcm.edu/packages/kbots/4/bitlocker_inventory.ps1.3e003b8c673fced08b5d9867ae6bd381]
[2016-05-13.16:04:27][runkbot:DownloadDependency      ] Downloading dependency from KBOX location [https://kbox.smcm.edu/packages/kbots/4/dcm_windows_inventory.ps1.5d466f58efb84c5f54bf91cdec188485]
[2016-05-13.16:04:28][runkbot:DownloadDependency      ] Downloading dependency from KBOX location [https://kbox.smcm.edu/packages/kbots/4/ddpe_windows_inventory.ps1.ad74284a0a4ad1a74af2361dd4c3c5be]
[2016-05-13.16:04:28][runkbot:DownloadDependency      ] Downloading dependency from KBOX location [https://kbox.smcm.edu/packages/kbots/4/tpm_inventory.ps1.7cac6d9bb056eed32552dfc2ddc4d614]
kbot[4:0] @ 2016-05-13T16:04:28 (output) Running as SYSTEM
kbot[4:0] @ 2016-05-13T16:04:28 (activity) Launching program: 'C:\Program Files (x86)\Dell\KACE\KDeploy' '-custominventory' wait='true'
kbot[4:0] @ 2016-05-13T16:04:28 (output) * <url> malformed
kbot[4:0] @ 2016-05-13T16:04:28 (output) * Closing connection -1
kbot[4:0] @ 2016-05-13T16:04:28 (output) libprotobuf ERROR ..\src\google\protobuf\message_lite.cc:123] Can't parse message of type "OOB_ClientServerMessageFSMI" because it is missing required fields: m_type, m_KUID

kbot[4:0] @ 2016-05-13T16:04:28 (output) Launched Process: KDeploy
kbot[4:0] @ 2016-05-13T16:04:28 (status) Submitted custom inventory results...
kbot[4:0] @ 2016-05-13T16:04:28 (output) Running as SYSTEM
kbot[4:0] @ 2016-05-13T16:04:28 (activity) Launching program: 'C:\Program Files (x86)\Dell\KACE\KInventory' '-machine -silent -out "C:\ProgramData\Dell\KACE\inventory.xml"' wait='true'
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:runInventory         ] KInventory   Begin capturing Inventory...
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:GetIdOfActiveUser    ] GetIdOfActiveUser: SECURITY_LOGON_TYPE: 2(18) There are no more files.
kbot[4:0] @ 2016-05-13T16:05:09 (output)
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:CInventoryData::Initi] KInventory   InventoryData attempting to open DB file [C]
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:CInventoryData::OpenD] KInventory   InventoryData opening DB
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:CInventoryData::OpenD] KInventory   InventoryData calling db.open
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:CInventoryData::Initi] KInventory   InventoryData opened DB successfully
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:CInventoryData::Initi] KInventory   InventoryData populated the DB
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:CCaptureInventory::In] Collecting Intel AMT Data
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:53][KInventory:CCaptureInventory::In] ACUConfig returned exit code 32, missing driver. Do not run ACUConfig with KInventory again.
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KInventory:runInventory         ] KInventory   Inventory Capture completed and stored in C:\ProgramData\Dell\KACE\inventory.xml
kbot[4:0] @ 2016-05-13T16:05:09 (output) [InventoryArgs.cpp::_parseArgs] SUCCESS
kbot[4:0] @ 2016-05-13T16:05:09 (output) [CInventoryRenderMachineXml::Initialize]
kbot[4:0] @ 2016-05-13T16:05:09 (output)    reportPath  : C:\ProgramData\Dell\KACE\inventory.xml
kbot[4:0] @ 2016-05-13T16:05:09 (output) Launched Process: KInventory
kbot[4:0] @ 2016-05-13T16:05:09 (activity) Launching program: 'C:\Program Files (x86)\Dell\KACE\KCOPY' '"C:\ProgramData\Dell\KACE\inventory.xml" "https://kbox.smcm.edu:443/service/inventory.php?KUID=9E95CB0B-C283-4648-991C-596E9552E28F&VERSION=6.4.180"' wait='true'
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KCopy:UploadUsingCurl           ] UploadFile:  Server gzip compression is active
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KCopy:GZipFile                  ] GZipFile: size of file C:\ProgramData\Dell\KACE\inventory.xml to zip is 303819
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KCopy:UploadUsingCurl           ] UploadFile:  uploading file C:\ProgramData\Dell\KACE\inventory.xml.gz to https://kbox.smcm.edu:443/service/inventory.php?KUID=9E95CB0B-C283-4648-991C-596E9552E28F&VERSION=6.4.180
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KCopy:UploadUsingCurl           ] UploadFile, curl stderr is stored in C:\ProgramData\Dell\KACE\user\KAgent.log
kbot[4:0] @ 2016-05-13T16:05:09 (output) Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
kbot[4:0] @ 2016-05-13T16:05:09 (output) Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KCopy:UploadUsingCurl           ] UploadFile:  Content-Encoding: gzip added to HTTP Header.
kbot[4:0] @ 2016-05-13T16:05:09 (output) Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
kbot[4:0] @ 2016-05-13T16:05:09 (output) Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KCopy:UploadUsingCurl           ] UploadFile: Uploaded to https://kbox.smcm.edu:443/service/inventory.php?KUID=9E95CB0B-C283-4648-991C-596E9552E28F&VERSION=6.4.180 Upload speed: 100936.000000 bytes/second
kbot[4:0] @ 2016-05-13T16:05:09 (output) Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
kbot[4:0] @ 2016-05-13T16:05:09 (output) Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KCopy:UploadUsingCurl           ] UploadFile:  Server gzip compression cleanup.
kbot[4:0] @ 2016-05-13T16:05:10 (output) Launched Process: KCOPY
kbot[4:0] @ 2016-05-13T16:05:10 (status) Submitted inventory to k1000...
kbot[4:0] @ 2016-05-13T16:05:10 (status) FINISH (In state 'verification_success')
[2016-05-13.16:05:10][runkbot:UploadUsingCurl         ] UploadFile:  Server gzip compression is active
[2016-05-13.16:05:10][runkbot:GZipFile                ] GZipFile: size of file C:\Users\IJKRIS~1\AppData\Local\Temp\dkl5114.tmp to zip is 5689
[2016-05-13.16:05:10][runkbot:UploadUsingCurl         ] UploadFile:  uploading file C:\Users\IJKRIS~1\AppData\Local\Temp\dkl5114.tmp.gz to https://kbox.smcm.edu/service/kbot_upload.php?BAD_MAC_IP=138.78.141.47&filename=KBOT_LOG.txt&mac=9E95CB0B-C283-4648-991C-596E9552E28F&kbotId=4
[2016-05-13.16:05:10][runkbot:UploadUsingCurl         ] UploadFile, curl stderr is stored in C:\ProgramData\Dell\KACE\user\KAgent.log
Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
[2016-05-13.16:05:10][runkbot:UploadUsingCurl         ] UploadFile:  Content-Encoding: gzip added to HTTP Header.
Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
[2016-05-13.16:05:10][runkbot:UploadUsingCurl         ] UploadFile: Uploaded to https://kbox.smcm.edu/service/kbot_upload.php?BAD_MAC_IP=138.78.141.47&filename=KBOT_LOG.txt&mac=9E95CB0B-C283-4648-991C-596E9552E28F&kbotId=4 Upload speed: 26489.000000 bytes/second
Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
[2016-05-13.16:05:10][runkbot:UploadUsingCurl         ] UploadFile:  Server gzip compression cleanup.
[2016-05-13.16:05:10][runkbot:CleanupLog              ] Cleaning up log file [C:\Users\IJKRIS~1\AppData\Local\Temp\dkl5114.tmp]
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

1
I was just going to add a couple of more things.  In the inventory window, with all of our other clients listed, the Agent version displays correctly. However, when you click on the device, to see the details of the machine, the agent version is listed incorrectly as 6.2.1025  We generally have been deploying the client through GPO. 6.2.1025 is the version that is currently being deployed.  It would hit the KACE and update to the 6.4.180 client on its first check-in.  I am trying to get our Admin to update the GPO to deploy the 6.4.180 client, rather than the older client.  On the computers that are experiencing the problem, I have uninstalled the KACE Agent by running amptools.exe uninstall and then manually removing the device from the console.  I then manually install the 6.4.180 agent but it keeps showing up in KACE as the older client.  I also had our admin create a new OU where the GPO that installs the old KACE agent is not applied.  I then manually install the 6.4.180 client and force it to check in.  Perhaps there is still some remnant of the 6.2.1025 agent on the machine?
Thanks in advance for any help you can provide,

Jeff
Answered 05/13/2016 by: smdjeff
Senior Yellow Belt

Please log in to comment
1
Your post would be easier to read if you applied the CODE style to the log file section.
Answered 05/16/2016 by: VBScab
Red Belt

Please log in to comment
1
Is this any better?  Thanks for the tip.


C:\windows\system32>cd C:\Program Files (x86)\Dell\KACE

C:\Program Files (x86)\Dell\KACE>runkbot 4 0
[2016-05-13.16:04:27][runkbot:GetKbot                 ] Kbot [4-0] not found locally, downloading ...
kbot[4:0] @ 2016-05-13T16:04:27 (status) START
[2016-05-13.16:04:27][runkbot:DownloadDependency      ] Downloading dependency from KBOX location [https://kbox.smcm.edu/packages/kbots/4/bitlocker_inventory.ps1.3e003b8c673fced08b5d9867ae6bd381]
[2016-05-13.16:04:27][runkbot:DownloadDependency      ] Downloading dependency from KBOX location [https://kbox.smcm.edu/packages/kbots/4/dcm_windows_inventory.ps1.5d466f58efb84c5f54bf91cdec188485]
[2016-05-13.16:04:28][runkbot:DownloadDependency      ] Downloading dependency from KBOX location [https://kbox.smcm.edu/packages/kbots/4/ddpe_windows_inventory.ps1.ad74284a0a4ad1a74af2361dd4c3c5be]
[2016-05-13.16:04:28][runkbot:DownloadDependency      ] Downloading dependency from KBOX location [https://kbox.smcm.edu/packages/kbots/4/tpm_inventory.ps1.7cac6d9bb056eed32552dfc2ddc4d614]
kbot[4:0] @ 2016-05-13T16:04:28 (output) Running as SYSTEM
kbot[4:0] @ 2016-05-13T16:04:28 (activity) Launching program: 'C:\Program Files (x86)\Dell\KACE\KDeploy' '-custominventory' wait='true'
kbot[4:0] @ 2016-05-13T16:04:28 (output) * <url> malformed
kbot[4:0] @ 2016-05-13T16:04:28 (output) * Closing connection -1
kbot[4:0] @ 2016-05-13T16:04:28 (output) libprotobuf ERROR ..\src\google\protobuf\message_lite.cc:123] Can't parse message of type "OOB_ClientServerMessageFSMI" because it is missing required fields: m_type, m_KUID
kbot[4:0] @ 2016-05-13T16:04:28 (output) Launched Process: KDeploy
kbot[4:0] @ 2016-05-13T16:04:28 (status) Submitted custom inventory results...
kbot[4:0] @ 2016-05-13T16:04:28 (output) Running as SYSTEM
kbot[4:0] @ 2016-05-13T16:04:28 (activity) Launching program: 'C:\Program Files (x86)\Dell\KACE\KInventory' '-machine -silent -out "C:\ProgramData\Dell\KACE\inventory.xml"' wait='true'
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:runInventory         ] KInventory   Begin capturing Inventory...
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:GetIdOfActiveUser    ] GetIdOfActiveUser: SECURITY_LOGON_TYPE: 2(18) There are no more files.
kbot[4:0] @ 2016-05-13T16:05:09 (output)
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:CInventoryData::Initi] KInventory   InventoryData attempting to open DB file [C]
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:CInventoryData::OpenD] KInventory   InventoryData opening DB
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:CInventoryData::OpenD] KInventory   InventoryData calling db.open
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:CInventoryData::Initi] KInventory   InventoryData opened DB successfully
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:CInventoryData::Initi] KInventory   InventoryData populated the DB
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:28][KInventory:CCaptureInventory::In] Collecting Intel AMT Data
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:04:53][KInventory:CCaptureInventory::In] ACUConfig returned exit code 32, missing driver. Do not run ACUConfig with KInventory again.
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KInventory:runInventory         ] KInventory   Inventory Capture completed and stored in C:\ProgramData\Dell\KACE\inventory.xml
kbot[4:0] @ 2016-05-13T16:05:09 (output) [InventoryArgs.cpp::_parseArgs] SUCCESS
kbot[4:0] @ 2016-05-13T16:05:09 (output) [CInventoryRenderMachineXml::Initialize]
kbot[4:0] @ 2016-05-13T16:05:09 (output)    reportPath  : C:\ProgramData\Dell\KACE\inventory.xml
kbot[4:0] @ 2016-05-13T16:05:09 (output) Launched Process: KInventory
kbot[4:0] @ 2016-05-13T16:05:09 (activity) Launching program: 'C:\Program Files (x86)\Dell\KACE\KCOPY' '"C:\ProgramData\Dell\KACE\inventory.xml" "https://kbox.smcm.edu:443/service/inventory.php?KUID=9E95CB0B-C283-4648-991C-596E9552E28F&VERSION=6.4.180"' wait='true'
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KCopy:UploadUsingCurl           ] UploadFile:  Server gzip compression is active
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KCopy:GZipFile                  ] GZipFile: size of file C:\ProgramData\Dell\KACE\inventory.xml to zip is 303819
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KCopy:UploadUsingCurl           ] UploadFile:  uploading file C:\ProgramData\Dell\KACE\inventory.xml.gz to https://kbox.smcm.edu:443/service/inventory.php?KUID=9E95CB0B-C283-4648-991C-596E9552E28F&VERSION=6.4.180
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KCopy:UploadUsingCurl           ] UploadFile, curl stderr is stored in C:\ProgramData\Dell\KACE\user\KAgent.log
kbot[4:0] @ 2016-05-13T16:05:09 (output) Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
kbot[4:0] @ 2016-05-13T16:05:09 (output) Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KCopy:UploadUsingCurl           ] UploadFile:  Content-Encoding: gzip added to HTTP Header.
kbot[4:0] @ 2016-05-13T16:05:09 (output) Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
kbot[4:0] @ 2016-05-13T16:05:09 (output) Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KCopy:UploadUsingCurl           ] UploadFile: Uploaded to https://kbox.smcm.edu:443/service/inventory.php?KUID=9E95CB0B-C283-4648-991C-596E9552E28F&VERSION=6.4.180 Upload speed: 100936.000000 bytes/second
kbot[4:0] @ 2016-05-13T16:05:09 (output) Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
kbot[4:0] @ 2016-05-13T16:05:09 (output) Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
kbot[4:0] @ 2016-05-13T16:05:09 (output) [2016-05-13.16:05:09][KCopy:UploadUsingCurl           ] UploadFile:  Server gzip compression cleanup.
kbot[4:0] @ 2016-05-13T16:05:10 (output) Launched Process: KCOPY
kbot[4:0] @ 2016-05-13T16:05:10 (status) Submitted inventory to k1000...
kbot[4:0] @ 2016-05-13T16:05:10 (status) FINISH (In state 'verification_success')
[2016-05-13.16:05:10][runkbot:UploadUsingCurl         ] UploadFile:  Server gzip compression is active
[2016-05-13.16:05:10][runkbot:GZipFile                ] GZipFile: size of file C:\Users\IJKRIS~1\AppData\Local\Temp\dkl5114.tmp to zip is 5689
[2016-05-13.16:05:10][runkbot:UploadUsingCurl         ] UploadFile:  uploading file C:\Users\IJKRIS~1\AppData\Local\Temp\dkl5114.tmp.gz to https://kbox.smcm.edu/service/kbot_upload.php?BAD_MAC_IP=138.78.141.47&filename=KBOT_LOG.txt&mac=9E95CB0B-C283-4648-991C-596E9552E28F&kbotId=4
[2016-05-13.16:05:10][runkbot:UploadUsingCurl         ] UploadFile, curl stderr is stored in C:\ProgramData\Dell\KACE\user\KAgent.log
Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
[2016-05-13.16:05:10][runkbot:UploadUsingCurl         ] UploadFile:  Content-Encoding: gzip added to HTTP Header.
Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
[2016-05-13.16:05:10][runkbot:UploadUsingCurl         ] UploadFile: Uploaded to https://kbox.smcm.edu/service/kbot_upload.php?BAD_MAC_IP=138.78.141.47&filename=KBOT_LOG.txt&mac=9E95CB0B-C283-4648-991C-596E9552E28F&kbotId=4 Upload speed: 26489.000000 bytes/second
Error renaming log file C:\ProgramData\Dell\KACE\user\KAgent.log to C:\ProgramData\Dell\KACE\user\KAgent1.log: Permission denied (13)
Error writing to log file: C:\ProgramData\Dell\KACE\user\KAgent.log (13) Permission denied
[2016-05-13.16:05:10][runkbot:UploadUsingCurl         ] UploadFile:  Server gzip compression cleanup.
[2016-05-13.16:05:10][runkbot:CleanupLog              ] Cleaning up log file [C:\Users\IJKRIS~1\AppData\Local\Temp\dkl5114.tmp]
                            
                                                                            

Answered 05/16/2016 by: smdjeff
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity
Admin Script Editor
Admin Script Editor is an integrated scripting environment available free here at ITNinja

Share