hi all
i need to add a certificate file in the Trusted Root Certification Authorities into the local machine and not local user through a msi i have been able to see it in local machine when in admin mode but its adding to local user in the the user mode how do i add it ONLY to local user in the user mode????
Please help......

Thanks in Advance..
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
CertMgr.exe -add "<certificiate> -s -r LocalMachine ROOT

Not sure thats going to work tbh as I dont normally put stuff into a specific store but:

http://msdn.microsoft.com/en-us/library/e78byta0(VS.80).aspx

Should help.

P
Answered 02/02/2009 by: Inabus
Second Degree Green Belt

Please log in to comment
0
Thnx a lot it worked i used certmgr.exe -add -c "<cert-file>" -s -r localMachine root
Answered 02/02/2009 by: bubble_buzz21
Senior Yellow Belt

Please log in to comment
0
Hi all
I have to add the certificate for peruser and not for the permachine .
When I am trying to add it using above mention command it is creating per machine keys (HKLM) and not the per user keys.(HKCU).
I have tried below commands but some prompt related to adding the certificate is coming for the confirmation brfore adding certificate.
certmgr.exe -add -c "<cert-file>" -s -r CurrentUser root
We need to supress the that dialog. Is their any silent parameter for certmgr.exe .

Thanks In advance.
Answered 09/03/2010 by: MsiCreator
Senior Yellow Belt

Please log in to comment
0
I don't know a lot about certificate storage but, from reading good old MSDN (damn useful, this Google thing, you know: I wonder if it'll catch on?), it would appear that:

- user-level storage is the default, so I'd leave off everything after the '-s' shown in your command line;
- there is no silent switch. Use 'Start /B [your command line]' to kick it off.
Answered 09/03/2010 by: VBScab
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity