I have discovered that when I capitalize the computername option in my unattended file once the machine is imaged it is lowercase. Does anyone know a way to make the capitalization hold?
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Answers

0
What deployment method are you using? Do you mean to say that in your unattend file you have IN CAPITOLS or that you have *?
The in the tags wont change anything, its the input that changes things. How are you filling in the computer name?

Cheers,
Col
Answered 03/21/2012 by: Roonerspism
Second Degree Brown Belt

  • damn lol it cut out my tags!
    see if this works, "...unattend file you have [ComputerName]IN CAPITOLS[/ComputerName] or that you have [COMPUTERNAME]*[/COMPUTERNAME]? "
  • Deploying with the K2 and in my unattended file I will name the computer like so.

    [UserData]
    ComputerName = "MYCOMPUTER01"

    Once it is finished and I login to the machine the computer name shows mycomputer01 instead of MYCOMPUTER01
  • [UserData]? Are you setting this under the specialize settings pass?
    Ie, here we have for our computer name section in unattend.xml (our * wildcard gives random machine name all in capitols):
    [settings pass="specialize"]
    [component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State"]
    [ComputerName]*[/ComputerName]
    [/Component]
    [/Settings]

    Are you deploying a WIM/Sysprepped K-Image or scripted install?
  • No I am doing a scripted install in the Kbox and I specify the computer name for the machine being imaged.
  • Are you able to post a copy of the unattend.xml file which is shown via the scripted installation detail page? Also, what happens if you apply the name as a random name via the * wild card?
  • The random name wouldn't have anything to do with it. I already posted that part of the unattended file.

    [UserData]
    ComputerName = "MYCOMPUTER01"
  • Are you using the old unattend.txt/.inf method from xp for setting this? when you say:
    [UserData]
    ComputerName = "MYCOMPUTER01"
    You arent giving me much to work with and that is the format of those old files. The format that I posted a few days ago is the format which is compatable with Win7 and an unattend.xml file. Are you actually using an unattend.txt/.inf file instead of xml? Are you using the propper tags? Now that I think of it you havent mentioned which OS you're deploying.
  • Yes this is to deploy windows XP SP3 using standard unattend.txt file. I actually used the k2 to generate the unattended file and then just changed the parameters I needed.
  • Ahhh jezuz, well that explains why things were getting lost in translation. I kept saying that your xml file this and your xml file that, and we're not even talking about the same operating system! lol.
    The OP should have probably included that...
    Unfortunately we run Win7 here and I dont have access to XP at all so I'm no longer able to help you out here.
    The only thing I can suggest is maybe instead of using a KACE created unattend.txt make one of your own and copy that via a post install task after all of your formatting is done to the location which it would normally use. Maybe there is something in the client which is dropping the case.
    Sorry dude, thought we were talking the same lingo.
Please log in to comment
Answer this question or Comment on this question for clarity