Unable to run Machine Action.  
Please check your Microsoft Internet Explorer Security Settings

  None of the IT department is able to get VNC remote tool to work from the K1000, we tried all the steps that dell offered from its walk through on the FAQ list from the k1000 which i provided below so people dont just post that while paper agian.  Anyways we went through step by step on the directions but still getting the error even in IE8 and IE9, we even went as far as completely opening everything but still getting the error, is there something we are missing on the Kace that i am over looking? any help would be much appricated!

 

These are the directions we followed.

INTERNET EXPLORER 6

Launch Internet Explorer 6 and navigate to:

1. Tools > Internet Options > Security
2. Select Trusted Sites Icon
-Add K1000 IP address to the zone
-Require Server Identification (Uncheck)
3. Click 'Custom Level' button
-Reset to Low or Medium Low
4. Under 'ActiveX Controls and Plugins'
-Automatic Prompting for ActiveX controls > Enable
-Download unisgned ActiveX controls > Enable
-Initialize & script ActiveX controls not marked safe for scripting > Enable
-Run ActiveX controls and plugins > Enable
5. Click 'OK'
6. Click 'Yes'
7. Click 'OK'

INTERNET EXPLORER 8

Launch Internet Explorer 8 and navigate to:

1. Tools > Internet Options > Security
2. Select Trusted Sites Icon > Sites Button
-Add K1000 IP address to the zone
-Require Server Identification (Uncheck)
-Click Close
3. Custom Level > Medium
4. ActiveX Controls Plugins
-Allow previously unused ActiveX controls > Enable
-Allow scriptlets > Enable
-Automatic Prompting for ActiveX controls > Enable
-Download unisgned ActiveX controls > Enable
-Initialize & script ActiveX controls not marked safe for scripting > Enable
-Run ActiveX controls and plugins > Enable
5. Click OK to close Security Settings Window
6. Click OK to close Internet Options Window

MACHINE ACTION SETTINGS:

1. Log into the K1000 Admin UI
2. Settings > Control Panel > General Settings
3. Scroll down to Machine Actions > Edit Mode
4. Verify the path variables to the VNC Executable on the PC
-Default is "%ProgramFiles%\\ultravnc\\vncviewer.exe" KACE_HOST_NAME [change this to reflect the actual path, if needed]
5. Click 'Set Actions' button

Note: When using Windows 7 64-bit and IE8 you must use the full path to the vncviewer.exe in the machine action settings.

Example:

"C:\\Program Files\\ultravnc\\vncviewer.exe" KACE_HOST_NAME

If your Internet Explorer settings are correct, and you continue to receive this error, also verify that the executable for the Machine Action command is in your system path. For example, if you are using the Dameware option, the path to dwrcc.exe must be in your system path for the command to launch.

 

Answer Summary:
Cancel
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Community Chosen Answer

2

Depending on how you install UltraVNC you need to specify this following path for a 64bit OS - 

"C:\\Program Files (x86)\\ultravnc\\vncviewer.exe" KACE_HOST_NAME

or 

"C:\\Program Files (x86)\\ultravnc\\vncviewer.exe" KACE_HOST_IP

 

Did you install the Server version (UltraVNC Server Only) on the target machine and the VNCViewer version on your machine? 

When you install the Server Version, both port 5800 & 5900 will be added as an Inbound Rule on Windows Firewall. 

Same goes for Microsoft RDP - mstsc.exe /v:KACE_HOST_NAME, you still need to enable & Allow connections for Remote Desktop on the target machine. 

 

Answered 04/16/2012 by: Aaron Cool
Red Belt

Please log in to comment

Answers

1

Those items have worked in the past. Did you check to make sure that you restarted teh browser after the changes, made sure your Machine Actions were set up, ports 5800 and 5900 were open?

these also only work on IE for now. 

Answered 04/16/2012 by: nshah
Red Belt

  • Yes i restarted IE after i made the changes and yes its only in IE. The machine actions are setup correctly the Dell Rep that gave us training on the Kace set it up for us. As far as the ports would that be for the Kace machines or the machines being remote too?
Please log in to comment
1

briggsa,

The settings should work. I've only seen one machine (out of MANY) that didn't work at all, and we eventually found a browser plug-in that was the culprit.  Have you tried any other Machine action, besides VNC?  Unfortunately, the error message is the same whether the problem is the IE Security Settings OR the excutable just doesn't work.  r2

Ron Colson

KACE Trainer

Answered 04/17/2012 by: ronco
Second Degree Brown Belt

Please log in to comment
This content is currently hidden from public view.
Reason: Removed by member request
For more information, visit our FAQ's.

0

I have VNC Viewer Plus, and I'm not sure if that gives me more capability, but this is the approach that I took so that I could have VNC auto-popup without even having to change IE settings, or add my kace addresses to my "Trusted Sites"

    kvm://admin:@KACE_HOST_NAME.yourdomainnamehere.com

This is using the syntax found after running:

C:\Program Files (x86)\RealVNC\VNCViewerPlus\vncviewerplus.exe /?

And like most "Help" commands, it gives you the entire list of options available to you via kvm:// or cmd.exe

Answered 07/31/2015 by: AeroMIS
White Belt

Please log in to comment
Answer this question or Comment on this question for clarity