Hi everyone,

I've used the Microsoft IEAK to create a customised IE9 installation. The customisation options work (for the most part) as Google gets set as default search and a few other settings come through, but I can't for the life of me stop the installation from restarting the PC. I want it to prompt but at this stage would even settle for a no restart.

Now the IEAK program creates the folders BrndOnly, FLAT, INS as you know, with MSI's, exe's etc in each. To be fair i've never known which one was the right one to use but have always gone with the MSI inside the FLAT folder. However even if I use the others, say in the INS folder, it still restarts.

The IE9 instructions on net say there are various command switches including /ieakpath-full:<path> but what path is it looking for, like what file? And is it that I'm not using this command swtich that is the problem? When I was configuring IE with IEAK, I selected the option to prompt for restart which is we know is currently ignored.

If I install using the MSI and use /norestart or /prompt restart, it still restarts. If I use the exe and norestart it still restarts. Just double clicking the file = restart.

So my quesion is how do I get it to NOT restart, but rather prompt like I want? I can't figure out the point of the IEAK asking what restart option to you want to use if its just going to flat out ignore you anyway, and restart regardless.

1 Comment   [ + ] Show Comment


  • I found out why users who have not logged on before aren't getting the IE icon on the taskbar and one which doesn't work in the Start menu and it's because for some reason the 32-bit IE is being pointed to the users H:\ drive (so it ends up looking for it at H:\Program Files\Internet Explorer\iexplore.exe). There's 2 problems there, the H:\ drive and the fact it doesn't have (x86) in the Program Files path.

    I simply use the IEAK to capture the IE install, why in h3ll it's setting random values such as this is currently beyond me. And annoying me a little.
Please log in to comment



I think you will have to edit the MSI, and change the CustomAction command lines to the EXE's used. The EXE's normally use /quiet /norestart.

Then run the MSI with REBOOT=ReallySuppress.

hope that helps.

Answered 08/13/2014 by: Badger
Red Belt

  • Thanks Badger but for some reason when I open the MSI in an editor it doesn't have many options available like a normal MSI does, definitely not the reboot option.
    However I recreated the package with the IEAK and selected no reboot rather than prompt and that has worked. Ideally I wanted a prompt to restart but it seems quite clear Microsoft has provided an option to select at the IEAK phase that doesn't actually work as advertsed but never mind.
    • so not your ideal solution, but your 2nd choice, that's not bad. I have not used the IEAK for years, I guess you are using GPO's to deploy the MSI, is that correct?
      I'm glad you having something that will work.
      • Hi, yeah deploying via GPO (could use KACE, GPO slightly better in this instance). However a bug got noticed where if a user hasn't logged onto the PC before IE gets upgraded, no IE icon is present on the taskbar and the start menu shortcut doesn't know what to do. Trying to sort that little problem out then I'm done :)
        Thanks for your input too.
      • I normally use the EXEs, but you did mention that you were putting in some other settings. Depending on your environment, I would go for the deploying the EXEs with your tool (KACE, in this case) then configure IE with a GPO. your new issue sounds interesting. Have you tried getting the user to log in and out again. Why, you might ask. ActiveSetup. IE uses active setup, if the GPO runs and starts the install, then lets them log in before the install has completed (it could happen, depending on the exits of the GPO, MSI and EXE's) so, try a log out and back in, hopefully you will see the ActiveSetup box appear in the top left corner. Cheers
Please log in to comment
Answer this question or Comment on this question for clarity