We are using Windows 2000 server and workstations.

When I assign an msi package as a "computer based policy" the software installs correctly - it is completely installed for the client.

This is in most cases perfectly okay. This is what we want.

However, when I assign one of these msi packages as a "user-based policy" - note I am not publishing I am using "advanced assignment" in Active Directory and
Group Policy, the software is not assigned. I do not see it appearing on the Programs Start menu after the user signs on - no advertised shortcuts either.

They have to go to the Add / Remove Programs applet and click on the Add New Programs button to see software waiting to install. They then install from here. If I do this step all is well.

My question, I have heard that Windows 2000 has a problem with assigned / advertised software installing at user logon. In Windows XP, you have a tick box in Active Directory and Group Policy that tells the system to install on logon - Windows 2000 does not have such a feature.

I want our user based policy msi packages to deploy for the client without them having to go to the Add / Remove Programs applet using Windows 2000 - is this possible?

Thanks for any insight into this one!

John Falloon
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


You may find your initial problem relates to your ALLUSERS property setting. If you're deploying as a user based app set this to either 2 or remove the ALLUSERS property alltogether. Also check for a CA in your sequence called ISInitAllUsers (or something along those lines). If you have it, get rid of it as it plays havock with user based installs and particular their shortcuts.

As for the "install at logon" try using the "Advanced" option when adding it to the AD. In there you should find an option to install at logon.
Answered 03/08/2005 by: $piKeIT
Senior Yellow Belt

Please log in to comment
Thanks again for the reply.

I will try adding the ALLUSERS entry to the property table and make it 2 and see if this makes a difference.

I have no Custom Action with "ISInitAllUser"

Thanks again.

Answered 03/09/2005 by: Zeke
Orange Belt

Please log in to comment
Answer this question or Comment on this question for clarity