I need to repackage Archibus Smart Client 20.0. I extracted the msi from the exe. The msi works fine when installed alone. But when i try to run it silently, it gives an error. The shortcuts are created but none of the files are copied.
I checked the log file and it displays that since UI is none, installing on server (something like that)...

Any clues on how i can make it to install silently.

0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Almost certainly, there is at least one Custom Action in the InstallUISequence which isn't in the InstallExecuteSequence. A comparison between logs taken from both installation scenarios will highlight that.
Answered 02/17/2012 by: VBScab
Red Belt

Please log in to comment
I'm not sure what you actually have for a version since 20.0 doesn't exist (and 20.1 hasn't been released).
But in any version there is a separate msi package file in addition to the executable installer; so you shouldn't need to extract the msi from the exe.

Get that msi file from your installation DVD (or download site). It should also be installed with administrator (registry edit) permissions.

Good luck,

Answered 02/21/2012 by: Mikeg95a
Yellow Belt

Please log in to comment

The reason why non of the files are copied is the main feature advertisement. You need to set the main feature to Disallow Advertisement and it works all fine. You can use the msi without any issues and you don't have to repack. The same is valid for version 21.2 which I've just finished working on.



Answered 06/30/2016 by: boyangk
White Belt

Please log in to comment
Answer this question or Comment on this question for clarity