Unfortunately because Apple changes things in every version of quicktime, the AppDeploy articles are all over the place on how to properly disable auto-update.  Some say it's in the .qtp files, others in the .plist file, others still in the .xml file.  I'm using Admin Studio to customize a transform, and no matter what I do, the stupid auto-update is checked after deploy.  Or is there a better/updated article somewhere out there?  I do NOT want to use VB scripting to accomplish this.  Just straight Admin Studio and if I need to add some extra files/registry keys AFTER deploy, I can use ZCM/ZCCM to do that.

0 Comments   [ + ] Show Comments


Please log in to comment

Community Chosen Answer

Answered 07/26/2012 by: jagadeish
Red Belt

Please log in to comment



This worked on 7.7.2

Navigate to where the installer was downloaded. Extract the .msi files with:

QuickTimeInstaller.exe /extract


msiexec /i "AppleSoftwareUpdate.msi" /qn

msiexec /i "AppleApplicationSupport.msi" /qn

del %SystemRoot%\Tasks\AppleSoftwareUpdate.job

Answered 07/26/2012 by: SMal.tmcc
Red Belt

  • If you want to disable to autoupdate then there is no need to installed Applesoftwareupdate.msi file at all. Otherwise, you are installing the file but never using it when autoupdate is disabled.

    I have tested to run the Quictime.msi with these switches " /qn DESKTOP_SHORTCUTS=NO SCHEDULE_ASUW=0 ASUWINSTALLED=0"and it installed quicktime without any issue. No autoupdater is installed and no desktop short cut .
Please log in to comment

I used Active Setup to copy the .qtp file that I created from a test install with the options I wanted to configure to%userprofile%\Local Settings\Application Data\Apple Computer\QuickTime

I changed properties REGSRCH_DESKTOP_SHORTCUTS=0 and SCHEDULE_ASUW=0 using my favorite msi editor and saved it as a transform.

Answered 08/02/2012 by: Estes
Second Degree Blue Belt

Please log in to comment
Answer this question or Comment on this question for clarity