I would like to discuss the v7.0-7.2 upgrades and all future upgrades.  I am currently on version 6.4.120822.  I have experienced that upgrading to any version after this one breaks many things in my system.  For example: email canned and custom triggers stop working, the modified date in my KACE ticket layout disappears, and the system runs slower.  I have tried upgrading to 7.0, 7.1, and now 7.2 last night.  With each of these upgrades I experienced the problems described and was forced to roll back the changes.  Each time I’ve brought this up to support am promised that it will get fixed in future upgrades.  Now I am at a crossroads thinking that I will have to remain on v6.4 in perpetuity because I can’t operate my help desk w/ all those problems.

 Also, it seems I’m not the only one experiencing these problems.  See links below and attached.

http://www.itninja.com/question/do-you-recommend-upgrading-k1000-to-7-0

http://www.itninja.com/question/any-one-have-problems-with-upgrading-to-k1000-7-0-or-k2000-4-0

http://www.itninja.com/question/regrets-upgrading-6-4-to-7-1-on-k1000-what-s-your-experience-been

http://www.itninja.com/question/k1000-upgrade-to-7-1-x-e-mail-not-working-tried-everything


- Mo


Answer Summary:
Cancel
1 Comment   [ + ] Show Comment

Comments

  • We're on 7.2 - and I wish I could go back to 6.4. The speed of the K1000 has just dropped dramatically - page loads are anywhere from 4-10 seconds sometimes, and you're stuck crossing your fingers that scripts and managed installs occur. We end up rebooting the K1000 weekly on Thursdays cause it seems that's the only way to get our scheduled reports to continue to trigger (we'd reboot - they would work, then at about a week, they would stop triggering).

    I am incredibly apprehensive about the upcoming 8.0, and currently worried about the future of the KACE product with Quest, to the point that we're keeping our eyes open for alternatives. With 1250+ clients scattered around the US, not something easy to overcome.
    • I feel the same way you do. I don’t think I’ll be upgrading anymore in the future. The risk outweighs the reward. They are not improving the product w/ each release, only making it worse.
    • I am still on 6.4. Even with 8.0 now released, I can't see upgrading and am also evaluating other alternatives. It is a pity, as the product was once fantastic.
Please log in to comment

Answer Chosen by the Author

3
We had some issues as well, a couple of things I've compiled since December 2016.

1- Forget about 7.0, it was a bad release, skip this one and go all the way up to 7.2 for both the appliance and the agents.

2- 6.4 vs 7.2 are very different, the K1 agent now uses a service named Konea, and it goes through port 443 (this is regardless if you are using SSL or not), you need t check if your machines can telnet your K1 FQDN via 443.

3- K1 Agents now use Powershell, If your workstations don't have a certain version of Poweshell, and are unable to open it, you will have inventorying issues.
See: https://support.quest.com/kace-systems-management-appliance/kb/225081
As a test:
- Open CMD as admin.
- Try to start Powershell from CMD. (just type Powershell and hit enter), it should output something like: 
PS C:\Windows\system32>
- If this action throws an error or a message, you will need to troubleshoot this on your devices.

4- 6.4 vs 7.2, their Databases are totally different, so many Custom Inventory Rules from the help-desk and SQL based reports might not work anymore. You can pay for those verification\changes,  to a team call Remote professional services, if want to you build them by yourself, better check the 7.2 Admin Guide, there is a section for the tables and fields, and also check this KB:  https://support.quest.com/kace-systems-management-appliance/kb/223753

5-In regards performance, if you have an old Physical KBOX, might be time to change, if you have a Virtual One (VMWare), check that your VMWAre tools are on version 10.x or greater, see: 
https://support.quest.com/kace-systems-management-appliance/kb/111198
**Remember you will need to get the VMwaretools ISO for Unix FreeBSD 64bits, it's like 40MB**

6- Performance Part2, In regards the WebUI slow, there is a chance you are trying to load too many Results at the same time. (for example loading 250 devices per page vs 100), or maybe your KBOX is getting too many task, check your Load Average Numbers, see this KB:  https://support.quest.com/kace-systems-management-appliance/kb/150659

7-Performance Part3, Check if your KBOX meets the Specifications, here are the ones for 7.2:
 Hardware: https://support.quest.com/technical-documents/kace-sma/7.2/technical-specifications-for-physical-appliances#TOPIC-758917
Virtual machines:  https://support.quest.com/technical-documents/kace-sma/7.2/technical-specifications-for-virtual-appliances#TOPIC-758924  --This one varies depending on your amount of devies--
**NOTE, if you are running an old OVF say from 6.3 or bellow, it might be better to deploy a new VM using the 7.2 OVF file**

8- 7.2 is not free from bugs, I would suggest contacting Support in regards the Helpdesk Module issues, I do not use it at all since we need a complex Ticketing solution. (we are using Sales-force). If it's a bug, they will tag your case and let you know when it's patched.

9- Remember we are entitled to have two K1's, one for production and one for lab testing, I have my lab K1 with 20 users I use as Guinea Pigs, if everything's fine after let's say... three weeks, then I proceed to update my main K1 and the rest of Devices on the building.

10- I would say avoid staying in 6.4, unless you are not willing to renew your Support Contract with Quest, 
See this note:   https://support.quest.com/product-notification/noti-00000012
and this: https://support.quest.com/kace-systems-management-appliance/kb/231848

And that's all I have folks!
So at this time is working fine for me, but I went to a hell first.
Answered 10/05/2017 by: Channeler
Brown Belt

Please log in to comment

Answers

0
After the upgrade to 7.2 we have attachments vanishing off of tickets and we are unable to do any kind of advanced search of Archived tickets. Both we are told are known issues that will be fixed in some unknown future release. We are very unhappy with the way Kace has gone and have began to discuss researching alternatives as well. 
Answered 10/04/2017 by: tramiksim
Third Degree Green Belt

Please log in to comment
Answer this question or Comment on this question for clarity