So my first agent installation is failing saying that the system is missing .net 1.1. The box is has .net 4, on W7 64. Do I really need to install an older version of .net? I thought each version contained everything you needed from the previous.

[11/05/10 08:37:23 AM] Begin provisioning...
[11/05/10 08:37:23 AM] Executing Windows platform provisioning.
[11/05/10 08:37:23 AM] Probing tcp ports for accessibility.
[11/05/10 08:37:23 AM] Port 139 [netbios-ssn] open.
[11/05/10 08:37:23 AM] Port 445 [microsoft-ds] open.


[11/05/10 08:37:39 AM] Executing remote communications:

Initializing RPC
Connecting to ADMIN$
Copying service file
Disconnecting ADMIN$
Connecting to IPC$


Creating service
Opening pipe to service
Sending commands
Sending login credentials
[MSGCODE: 000] Begin agent_provision.bat processing.
[MSGCODE: 064] Detected 64-bit platform
[MSGCODE: 066] .NET 1.1 not found. Enable install on 64 bit systems or preinstall prior to provisioning KBOX agent.
[MSGCODE: 002] KBOX Agent is not installed.
[MSGCODE: 092] AMP is not connected.
[MSGCODE: 095] KUID file not written by kinstaller.
[MSGCODE: 100] agent_provision.bat exiting.
exit code: 0Removing service
Connecting to ADMIN$
Deleting service file
Disconnecting ADMIN$


End of remote communications.

[11/05/10 08:37:39 AM] End provisioning run.
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


The good news is that the upcoming 5.2 release will rid us of our .NET dependencies once and for all. In the mean time, we continue to require .NET 1.1 as we have seen inconsistent behavior with newer .NETs that we could never pinpoint, and that would go away if we installed .NET 1.1. You might be able to run the kinstaller.exe directly on systems with newer versions of .NET, but it is an unsupported configuration, and support will ask you to install .NET 1.1 if there is any issue with agents.
Answered 11/05/2010 by: chrisgrim
Senior Purple Belt

Please log in to comment
Thanks for the quick reply. I will try running it manually on the client (although obviously that's non-starter in the long term). All of my W7 boxes have .net 4. Is there an eta on release of 5.2? Does the current version work consistently on .net 3.5?
Answered 11/05/2010 by: lquattrochi
Yellow Belt

Please log in to comment
After speaking with support I was told that 5.2 is due in December. In addition, you can actually deploy .net 1.1 during the agent provisioning process. I just needed to check the box to deploy .net 1.1 to x64 machines in the advanced options.
Answered 11/05/2010 by: lquattrochi
Yellow Belt

Please log in to comment

Just be careful when deploying .net to x64 machines running

It is a known Microsoft issue that .net will override on web servers.
Answered 11/10/2010 by: dchristian
Red Belt

Please log in to comment
It's 7/13/2011. Still no 5.2 agent update? We are on the latest 5.1.38724 and still have this error when attempting to push the agent out to a newly built Win Server 2008 R2 box with .Net 4.
Answered 07/13/2011 by: mattpenner
Senior Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity