I had posted earlier about the Setup Completed Successfully Dialog - OK. I think I have this working now. However, I now noticed that after the quiet /qn install the program does not show up in Add/Remove Programs. I shows up when you run the program without switches. Any Ideas?
0 Comments   [ + ] Show Comments


Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Property Table - ARPSYSTEMCOMPONENT -- This property decides whether install is published in Add/Remove programs - 1 = NO , 0 (or blank) = YES

Check Custom Actions for a UILEVEL <=3 Set Property ARPSYSTEMCOMPONENT=1

UILEVEL = 4 Reduced UI
UILEVEL = 3 Basic UI
UILEVEL = 2 Silent UI

Something to check ... MSI packager may have thought that if you are installing the application silent then it would be considered Mandatory .. and in that case why give the user a way to uninstall it.
Answered 10/12/2006 by: gmorgan618
Blue Belt

Please log in to comment
I checked for the ARPSYSTEMCOMPONENT properties with ORCA. This component is not listed in the property table. Can I add this property to the tabel? The same goes for the UILEVEL....no instance.
Answered 10/12/2006 by: madsquirrel21
Senior Yellow Belt

Please log in to comment
The UILEVEL property will be set during install and it's value will depend on how you installed it; no UI, Basic UI, Full UI and so on.

If you set the ARPSYSTEMCOMPONENT property to 1 the application will NOT show up under Add/Remove Programs, so you wouldn't want to do this as you want it to be displayed.

Log the installation when running it with /qn and see what custom action setting the ARPSYSTEMCOMPONENT property or if the DisplayName under HKLM\SOFTWARE\...\Uninstall gets removed by a custom action.
Answered 10/12/2006 by: AngelD
Red Belt

Please log in to comment
Answer this question or Comment on this question for clarity