Adobe has done it again.. Has anyone looked at the new 11 release (sw_lic_full_installer.exe)?
Unless I got the wrone one.. there is not an MSI that extracts out.. zilch.. nothing... They also have an uninstaller for it (sw_uninstaller.exe). Both available from http://www.adobe.com/shockwave/download/alternates/#sp

Regards..
Mike
0 Comments   [ + ] Show Comments

Comments

Please log in to comment

Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.

Answers

0
Have you checked whether a separate MSI-based redistributable is available from Adobe ? That was the case (I think) with v10. Take a look at the following link

http://www.adobe.com/licensing/distribution/

You'll need to sign a license agreement with Adobe if you go down this route.

Regards,

Spartacus
Answered 04/11/2008 by: spartacus
Black Belt

Please log in to comment
0

http://www.adobe.com/licensing/distribution/


Thanks Spartacus... that is exactly what was needed.....[:)]
Answered 04/11/2008 by: makelley
Senior Yellow Belt

Please log in to comment
0
OK... what the heck (PG rating) am I missing on this auto update setting in order to disable it....

Is anyone having the same issues I am with trying to get the auto update disabled?
Here is the process I have implimented so far

First thing I do is remove the HKCU Macromedia Shockwave xx settings..

1-Registry settings have been set to "N" on the AutoUpdate key
2- Reg key "N" on CollectStatistics

the currentupdateversion key shows 1040025 which I really dont understans since this is 11.0.0.429, but then again... the key shows as Shockwave 10 in both LM and CU hives...

3-nextpingdate=0
4-otb=0
the unicontrol key settings...
alywaysregister=n
CollectStatistics=n
DefaultAllowMMMail=n
defaultautoupdate=n
defaultcollectstats=n
DoMandatoryUpdates=n
OfferOptionalUpdates=n
PingEnabled=n
remotecheckforupdatesurl=0
updateshockwaveurl=blank (url removed)

I have removed the Shockwave_updater component and all refrences to the updater.exe

Now.. you would think this would just about break the shockwave app let alone the autoupdates...
however.. we still get the auto update notification when one is available......

What gives????
Any help as always is appricated or if there is a whitepaper like there is with flash would be great!
Answered 04/22/2008 by: makelley
Senior Yellow Belt

Please log in to comment
0
Hey makelly, have you found a solution to your problem?
I'm experiencing the same issue with Shockwave 10.1.4.020 and was wondering if you managed to go farther?
I have done the same things you've described, plus tried every bit of solution found in the following link http://www.appdeploy.com/packages/detail_pf.asp?id=386 but no success...

Whenever I browse a web site containing shockwave objects (with a clean HKCU \Macromedia\Shockwave), i get a shockwave nag screen update notification each time I re-log into windows.

I cannot find a solution to avoid the HKCU\..\RunOnce key being populated with the postupdate.exe....

Has anyone managed to circumvent the issue?
Answered 09/01/2008 by: alansch64
Orange Belt

Please log in to comment
0
Hi folks,
i see a lot of confusion here.
Be aware of the right registry locations for this:
For shockwave 10 it is:
SOFTWARE\Macromedia\Shockwave 10\AutoUpdate
For shockwave 11 it has changed to:
SOFTWARE\Adobe\Shockwave 11\AutoUpdate

Open the corporate MSI installers and look for this keys in the registry table.
Then you can easily generate a transform for it.
Regards, Nick
Answered 09/01/2008 by: nheim
Tenth Degree Black Belt

Please log in to comment
0
Hi Nick,

No confusion here (I think ;-)), I indeed work with Shockwave 10 in the keys HKLM (and HKCU)\SOFTWARE\Macromedia\Shockwave 10\
I have applied an mst using and testing all the different tips found in this link http://www.appdeploy.com/packages/detail_pf.asp?id=386
but could not make it work.

If my HKCU is clean, (wich means I've never ran into a shockwave object yet) and I log onto a website containg shockwave animations then my HKCU gets populated with shockwave parameters.
Indeed the HKCU inherits of my personal modified HKLM parameters but that does not seem to bother him....
the HKCU\..\RunOnce\ also gets populated with the postupdate.exe and I still get the shockwave nag screen update notification next time I relog.

Meanwhile, If the HKCU\Software\Macromedia\Shockwave 10\ keys allready exists and I simply change the default values from "y" to "n" in the SOFTWARE\Macromedia\Shockwave 10\collectstats. Then the [font="times new roman"]HKCU\..\RunOnce\ key does not receive the postupdate.exe command.

I'm a bit lost...
Answered 09/03/2008 by: alansch64
Orange Belt

Please log in to comment
0
Hi Alan,
which version are you using? Retail or corporate?
Why do you want to use an older version?
We always use the corporate MSI package and i did not experience this problems.
The MSI package uses Active Setup to copy the HKLM settings over to HKCU.
If you are playing around with the same version and test it always with the same user, AS doesn't run, because the AS regkeys are already set in the HKCU branch.
Regards, Nick
Answered 09/03/2008 by: nheim
Tenth Degree Black Belt

Please log in to comment
0
Hi Nick,
Thanks for posting back.
I'm using a corporate msi downloaded from the adobe web site.
I thought Active Setup populates the HKCU keys only when you logged on ?
My Macromedia HKCU settings are only populated when I browse a web site containing Shockwave animations.
When testing I systematically remove the application via and clean the HKCU\Software\Macromedia settings before testing again....I also change test users and use vmware machines.

We're using an old version because we do not need a new version, I believe ;-) (take that for an answer ;-))
I'm no decision maker concerning this part (unfortunately) ;-)
The thing is I've been asked to rework on our shockwave mst because of the Update screen problem.
The original package we distribute had the keys
SOFTWARE\Macromedia\Shockwave 10\AutoUpdate & SOFTWARE\Macromedia\Shockwave 10\CollectStatistics set to "n" plus it delt with 'the setPROFILE' CustomAction error and it worked great untill adobe came up with a version 11, now update pop ups are flourishing all over are network.... so the "n" setting did not work so great finally...

I'm certainly doing something wrong but can't put a hand on it.

If I can't manage to disable this shockwave 10 autopupdate s##t I 'll try to push towards version 11 ... at least for some sure time it will not try to update itself... ..(untill maybe version 12 comes along .... ;-))

Regards,
Alan
Answered 09/03/2008 by: alansch64
Orange Belt

Please log in to comment
0
Hi Alan,
I thought Active Setup populates the HKCU keys only when you logged on
Yes, but only the very first time after installing it. And only, if there is not alread a populated key for the product in its current version under:
HKCU\Software\Microsoft\Active Setup\Installed Components
Here are all the keys we alter to make sure no update/pop for the users kicks in:

registry56.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B 2 SOFTWARE\Macromedia\Shockwave 10\uicontrol\defaultcollectstats n registry10.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B
registry21.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B 2 SOFTWARE\Macromedia\Shockwave 10\CollectStatistics n registry10.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B
registry55.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B 2 SOFTWARE\Macromedia\Shockwave 10\uicontrol\defaultautoupdate n registry10.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B
registry61.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B 2 SOFTWARE\Macromedia\Shockwave 10\uicontrol\DoMandatoryUpdates n registry10.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B
registry49.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B 2 SOFTWARE\Macromedia\Shockwave 10\uicontrol\CollectStatistics n registry10.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B
registry34.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B 2 SOFTWARE\Macromedia\Shockwave 10\uicontrol\AlwaysRegister n registry10.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B
registry94.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B 2 SOFTWARE\Macromedia\Shockwave 10\uicontrol\OfferOptionalUpdates n registry10.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B
registry20.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B 2 SOFTWARE\Macromedia\Shockwave 10\AutoUpdate n registry10.10E6AC52_E5A9_499F_9BBC_7C1B55E4CA5B


Regards, Nick
Answered 09/03/2008 by: nheim
Tenth Degree Black Belt

Please log in to comment
0
Back in the darkest recesses of my mind is a dim recollection of a temporary hack for a similar situation (or it may even have been for an Adobe app...) which involves divining the name of the update server, then adding it to the local HOSTS file but pointed to the loopback address. For example, if the update host is called 'update.adobe.com', then add this line to the foot of the HOSTS file:

update.adobe.com 127.0.0.1
Answered 09/03/2008 by: VBScab
Red Belt

Please log in to comment
0
Hi,

Well again, unfortunally none of all that worked... I'm starting to believe that the msi used is not corporate. It's the only reason I can find.
The initial package was made by someone else, I'm just taking over, and even though the politic here is to ue only corporate msi, I'm starting to think that I'm not using the right one..
Is there a way by editing the msi to know what kind of version I'm using, corporate or retail ?
Here's what I've got :
ProductVersion 10.1.4.020
ProductName Adobe Shockwave Player
ProductLanguage 1033
ProductCode {A7DB362E-16DC-4E29-8A34-E74381E00B5B}
The size of the msi is 5mb.
If my MSI is not good, how can get a hold of a shockwae v10 corporate msi ?
In parrallel I'm also working on pushing to v11...
Answered 09/05/2008 by: alansch64
Orange Belt

Please log in to comment
0
If it helps, I have v10 (downloaded in January of this year) in EXE form, 'Shockwave_Installer_Full.exe', 5,699,496 bytes. It extracts 'sw_lic_full_installer.msi', 5,405,184 bytes. The MSI's properties:

ProductVersion 10.2.0.023
ProductCode {1BDC9633-895B-4842-BCB6-8FA1EC2A3C5A}

I *did* find 10.1.4.020 here http://www.filehippo.com/download_shockwave/1642/
Answered 09/05/2008 by: VBScab
Red Belt

Please log in to comment
0
Hi Alan,
the productcode is the right one.
Regard, Nick
Answered 09/05/2008 by: nheim
Tenth Degree Black Belt

Please log in to comment
0
Thanks guys, but since we also had a lot of other different problems with the previous v10 package, I finally managed to push on the installation of v11.
So I'm now working on this package now.
I have donwload corportate version 11 (sw_lic_full_installer.msi 12.4 Mo)
I can't test the if the update will be a futur pain or not , but another funny thing is happening.

I uninstalled V10 and Installed v11 (manually)
If I go on the adobe site to test my plugin http://www.adobe.com/fr/shockwave/welcome/ I get a version 10.4r25 if I'm logged in with admin rights. (previous installed v10 gave me a 10.4r21 version)
Is this normal ? Shouldn't it be showing a v11 point something version ?

Another thing wich bothers me more is that if I log in with my standard user account I get v10.4r21. instead of 10.4r25
I believe plugin for IE is the file C:\windows\system32\adobe\director\SwDirdll. (Wich is version 11.0.0.465)
It looks like something is not quite right here ... does anybody know what is causing this strange behaviour ?
If I test the installation by going on to that site for example http://www.explorelearning.com/index.cfm?method=cCorp.dspTest it shows that installed shockwave version is 11.
The result from the adobe web site is confusing me.

Thanks.
Answered 09/08/2008 by: alansch64
Orange Belt

Please log in to comment
0
What value does the ProductVersion property in the MSI have? Can you be sure that that file is used to detect the version? I'd knock up a quick script to get the file version property from all the installed files and compare them against the info in the MSI.
Answered 09/08/2008 by: VBScab
Red Belt

Please log in to comment
0
Hi Ian,

Here are some values from the property table.
ProductCode {AD72CFB4-C2BF-424E-9DF0-C7BAD1F30A11}
ProductName Adobe Shockwave Player
ProductVersion 11.0
Manufacturer Adobe Systems, Inc.

Can you be sure that that file is used to detect the version?

If you are talking about the SwDirdll file.. I have no idea.
but the previous one in C:\WINDOWS\system32\Macromed\Director (from V10) is removed during uninstall.
Shockwave v11 seems to be correctly installed.
The only issue is this weird versioning showing off on the adobe site.
I believe that the adobe's new corporate msi (v11) should naturally replace a corporate msi v10 without much tweaking, wouldn't it ? Or is that only in a perfect world... ;-)
Answered 09/08/2008 by: alansch64
Orange Belt

Please log in to comment
1
when it comes to adobe products, hope is but a forlorn grasp @ straws, best practices nothing but a joke, & a pint of guinness when you finally get it working, your only solace...
Answered 09/08/2008 by: kiptek
Second Degree Green Belt

Please log in to comment
1
Hi,

I was wondering earllier why I'd see sporadically a version 10.4r25 or a 11.0r465 on the web site http://www.adobe.com/fr/shockwave/welcome/ when testing the Shockwave plugin version.
Inf fact I found out that, the switching of the version appears when you check/uncheck the "Allow backward compatibility" and reload the web page. You can adjust this setting with a right click on the shockwave animation and by going in the property menu.

It's defautly checked.
Does anyone know what this option is really about ?
What are the risks of playing around with this setting ?
Anyway I now know that I'm using the right version of shockwave.

I have now ran into another issue... yep nothing's easy specially with adobe... (btw I liked your prose kiptek ;-))
An intranet page here needs an xtra to be installed by the user.
On some computers I can clearly see the message asking to install the xtra, but on some other the message doesn't appear, the xtra is not installed and of course the web site freezzes because it cannot load the xtra.
Anyone as come throught that kind of problem ?

thanks.
Answered 09/15/2008 by: alansch64
Orange Belt

Please log in to comment
0
Answered 09/15/2008 by: alansch64
Orange Belt

Please log in to comment
0
If you have a current license, term=1year, the MSI download is here:
http://download.macromedia.com/pub/shockwave/default/english/win95nt/latest/sw_lic_full_installer.msi
This assumes you have a valid distributor license as mentioned earlier. http://www.adobe.com/licensing/distribution/
Answered 11/25/2008 by: geoffpickard
Yellow Belt

Please log in to comment
0
Wow! I tried to get this working about 6 months ago. I went to HCLU and disableded collectstatistics and autoupdate just like you all did. I then installed the msi w/ the nic disabled to see what gets installed. It seems that 11 and 10.4.0.25 get installed also.
I have tried checking to see what else gets downloaded by going to
http://123games.ctp-design.net/shockwave-retro-games/, which has really old shockwave games.
I was also told that Shockwave 8 and maybe even 7 get invisibly downloaded on some games. THIS CAN't BE TRUE. i have tested that i haven't seen that.

Bottom line, can't Shockwave 11 just be installed and not have 10?
Answered 01/15/2009 by: fenster67
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity