We are having a problem trying to add administrator rights from our domain as part of our Windows 7 silent install.
Currently, our install will install Windows, base software, rename and join the domain ok.
Has anyone worked out how to, and where to script this? Unattend file? Post install? Scripted in after the join domain (think it might be this, but unable to make something work).
We followed the KACE recommended guide for our join domain.

Thanks in advance!

P.S. Just about to start the three day weekend.. so might be a bit slower on checking this than usual...
0 Comments   [ + ] Show Comments


Please log in to comment

Community Chosen Answer

We use Group Policy - Computer Configuration, Policies, Winows Settings, Security Settings, Restricted Groups. Add you administrators here as members of BUILTIN\Administrators.
Answered 06/10/2011 by: kena
Senior Yellow Belt

Please log in to comment
Rating comments in this legacy AppDeploy message board thread won't reorder them,
so that the conversation will remain readable.


Thanks for you quick reply!
We will definatly have a look at that and see if it's workable in our situation
Cheers [:)]
Answered 06/10/2011 by: clebas
Yellow Belt

Please log in to comment
You could make a batch script:

net localgroup "Administrators" "DOMAIN\USER" /add

and you use that line multiple times and it works. we do it in our silent install .
Answered 06/13/2011 by: ngbrown24
Blue Belt

Please log in to comment
it works perfectly. Thanks
Answered 06/17/2011 by: samtng
Yellow Belt

Please log in to comment
Answer this question or Comment on this question for clarity